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1. Introduction to the Ubuntu Desktop Guide

Welcome to the Ubuntu Desktop Guide, a comprehensive guide to using Ubuntu in a

desktop environment.

The guide is divided into the following chapters:

1. Getting Started - An introduction to the world of Ubuntu and some basic concepts

which are useful when getting started.

2. Adding, Removing and Updating Applications - How to manage your software in

Ubuntu.

3. Common Tasks - Performing common tasks on Ubuntu, including playing music and

video, using the internet, office and graphics programs and more.

4. Configuring Your System - Change the settings of your Ubuntu system according to

your needs.

5. Getting More Help - Where to find help if this guide doesn't provide the answer.

HTML and PDF versions of the manual are available online at the Ubuntu Documentation

website [http://help.ubuntu.com].

You can buy this guide in book form from our Lulu store

[http://www.lulu.com/ubuntu-doc]. You will only pay for the price of printing and postage.

http://help.ubuntu.com
http://help.ubuntu.com
http://help.ubuntu.com
http://www.lulu.com/ubuntu-doc
http://www.lulu.com/ubuntu-doc
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2. Conventions

The following notes will be used throughout the book:

A note presents interesting, sometimes technical, pieces of information related to

the surrounding discussion.

A tip offers advice or an easier way of doing something.

A caution alerts the reader to potential problems and helps avoid them.

A warning advises the reader of a hazard that may arise in a given scenario.

Cross-reference conventions for print will be displayed as follows:

• Links to other documents or websites will look like this [http://www.ubuntu.com].

PDF, HTML, and XHTML versions of this document will use hyperlinks to

handle cross-referencing.

Type conventions will be displayed as follows:

• File names or paths to directories will be shown in monospace.

• Commands that you type at a Terminal command prompt will be shown as:

command to type                                 

• Options that you click, select, or choose in a user interface will be shown in monospace

type.

Menu selections, mouse actions, and keyboard short-cuts:

• A sequence of menu selections will be displayed as follows: File  →  Open

• Mouse actions shall assume a right-handed mouse configuration. The terms “click”

and “double-click” refer to using the left mouse button. The term “right-click” refers to

using the right mouse button. The term “middle-click” refers to using the middle mouse

button, pressing down on the scroll wheel, or pressing both the left and right buttons

simultaneously, based on the design of your mouse.

• Keyboard shortcut combinations will be displayed as follows: Ctrl-N .Where the

conventions for “Control”, “Shift,” and “Alternate” keys will be Ctrl, Shift, and Alt,

respectively, and shall mean the first key is to be held down while pressing the second

key.

http://www.ubuntu.com
http://www.ubuntu.com
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3. Contributing and Feedback

This book is developed by the Ubuntu Documentation Team

[https://wiki.ubuntu.com/DocumentationTeam]. You can contribute to this document by

sending ideas or comments to the Ubuntu Documentation Team mailing list. Information

about the team, its mailing lists, projects, etc. can be found on the Ubuntu Documentation

Team Website [https://wiki.ubuntu.com/DocumentationTeam].

If you see a problem with this document, or would like to make a

suggestion, you can simply file a bug report at the Ubuntu Bugtracker

[https://launchpad.net/products/ubuntu-doc/+bugs]. Your help is vital to the success of our

documentation!

Many thanks,

-Your Ubuntu Documentation Team

https://wiki.ubuntu.com/DocumentationTeam
https://wiki.ubuntu.com/DocumentationTeam
https://wiki.ubuntu.com/DocumentationTeam
https://wiki.ubuntu.com/DocumentationTeam
https://wiki.ubuntu.com/DocumentationTeam
https://launchpad.net/products/ubuntu-doc/+bugs
https://launchpad.net/products/ubuntu-doc/+bugs
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Chapter 1. Getting Started
This chapter introduces the world of Ubuntu and some basic concepts which are useful

when getting started with an Ubuntu system.
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1. About Ubuntu

Thank you for your interest in Ubuntu 6.06 LTS - the Dapper Drake release.

Ubuntu is an entirely open source operating system built around the Linux kernel.

The Ubuntu community is built around the ideals enshrined in the Ubuntu Philosophy

[http://www.ubuntu.com/ubuntu/philosophy]: that software should be available free of

charge, that software tools should be usable by people in their local language and despite

any disabilities, and that people should have the freedom to customize and alter their

software in whatever way they see fit. For those reasons:

• Ubuntu will always be free of charge, and there is no extra fee for the "enterprise

edition," we make our very best work available to everyone on the same Free terms.

• Ubuntu includes the very best in translations and accessibility infrastructure that the free

software community has to offer, to make Ubuntu usable for as many people as possible.

• Ubuntu is released regularly and predictably; a new release is made every six months.

You can use the current stable release or the current development release. Each release is

supported for at least 18 months.

• Ubuntu is entirely committed to the principles of open source software development; we

encourage people to use open source software, improve it and pass it on.

The Ubuntu community is comprised of developers, programmers, testers, techwriters,

documentation testers, translators, and most importantly, the people who use Ubuntu every

day. We invite you to join this community and help make Ubuntu the operating system

you, your family, your friends, and your colleagues will love to use. Help us translate

Ubuntu into your language, try it on new and unusual hardware, improve the experience of

other users with hints, tips, and FAQs, or help to shape the direction Ubuntu is headed by

providing feedback about the software you love most.

Find out more at the Ubuntu website [http://www.ubuntu.com].

1.1. About the Name

Ubuntu is a South African ethical ideology focusing on people's allegiances and

relations with each other. The word comes from the Zulu and Xhosa languages. Ubuntu

(pronounced "oo-BOON-too") is seen as a traditional African concept, is regarded as one

of the founding principles of the new republic of South Africa and is connected to the idea

of an African Renaissance.

A rough translation of the principle of Ubuntu is "humanity towards others". Another

translation could be: "the belief in a universal bond of sharing that connects all humanity".

"A person with ubuntu is open and available to others, affirming of others,

does not feel threatened that others are able and good, for he or she has a

http://www.ubuntu.com/ubuntu/philosophy
http://www.ubuntu.com/ubuntu/philosophy
http://www.ubuntu.com
http://www.ubuntu.com
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proper self-assurance that comes from knowing that he or she belongs in a

greater whole and is diminished when others are humiliated or diminished,

when others are tortured or oppressed."

—Archbishop Desmond Tutu

As a platform based on GNU/Linux, the Ubuntu operating system brings the spirit of

ubuntu to the software world.

1.2. Free Software

The Ubuntu project is entirely committed to the principles of open source software

development; people are encouraged to use open source software, improve it, and pass it

on. This means that Ubuntu is and will always be free of charge.

However, this means more than just being available at zero cost. The philosophy of free

software is that people should be free to use software in all the ways that are "socially

useful". "Free software" doesn't just mean that you shouldn't have to pay for it, it also

means that you should be able to use the software in any way you wish: the code that

makes up free software is available for anyone to download, change, fix, and use in any

way. So apart from the fact that free software is often available without charge, this

freedom also has technical advantages: when programs are developed, the hard work of

others can be used and built upon. With non-free software, this cannot happen and when

programs are developed, they have to start from scratch. For this reason the development of

free software is fast, efficient and exciting!

You can find out more about the philosophy of free software here

[http://www.gnu.org/philosophy/].

1.3. The Difference

There are many different operating systems based on GNU/Linux: Debian, SuSE, Gentoo,

RedHat, and Mandriva are examples. Ubuntu is yet another contender in what is already a

highly competitive world. So what makes Ubuntu different?

Based on Debian, one of the most widely acclaimed, technologically advanced, and

well-supported distributions, Ubuntu aims to create a distribution that provides an

up-to-date and coherent Linux system for desktop and server computing. Ubuntu includes

a number of carefully selected packages from the Debian distribution and retains its

powerful package management system which allows easy installation and clean removal

of programs. Unlike most distributions that ship with a large amount of software that

may or may not be of use, Ubuntu's list of packages is reduced to a number of important

applications of high quality.

By focusing on quality, Ubuntu produces a robust and feature-rich computing environment

that is suitable for use in both home and commercial environments. The project takes the

http://www.gnu.org/philosophy/
http://www.gnu.org/philosophy/
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time required to focus on finer details and is able to release a version featuring the latest

and greatest of today's software once every 6 months. Ubuntu is available in flavours for

the i386 (386/486/Pentium(II/III/IV) and Athlon/Duron/Sempron processors), AMD64

(Athlon64, Opteron, and new 64-bit Intel processors), and PowerPC (iBook/Powerbook,

G4 and G5) architectures.

1.4. Long-Term Support

Every Ubuntu release is supported for at least 18 months with security and other updates.

Ubuntu 6.06 LTS is a special enterprise-ready release, and is supported for 3 years on the

desktop, and 5 years on the server. The development process of Ubuntu 6.06 LTS was

slightly longer than usual to concentrate on a number of areas:

• Quality Assurance

• Localisation

• Certification

As a result, it will be possible to rely on Ubuntu 6.06 LTS for a longer period than usual.

Therefore this release of Ubuntu is referred to as "LTS" or "Long-Term Support".

1.5. The Desktop

The default desktop environment for Ubuntu is GNOME [http://www.gnome.org/], a

leading UNIX and Linux desktop suite and development platform.

Another leading UNIX and Linux desktop is KDE [http://www.kde.org/]. The Kubuntu

[http://www.kubuntu.org] project offers Ubuntu users an alternative choice to the default

GNOME desktop environment. Thanks to the efforts of the Kubuntu team, Ubuntu

users are now able to install and use the KDE desktop easily on their system. To get a

working install of Kubuntu on an Ubuntu install, install the kubuntu-desktop package.

Once kubuntu-desktop is installed, one can choose to use either a Gnome or KDE desktop

environment.

1.6. Version and Release Numbers

The Ubuntu version numbering scheme is based on the date we release a version of the

distribution. The version number comes from the year and month of the release rather than

reflecting the actual version of the software. Our first release (Warty Warthog) was in

October 2004 so its version was 4.10. This version (Dapper Drake) was released in June

2006 so its version number is 6.06 LTS.

1.7. Backing and Support

Ubuntu is maintained by a quickly growing community. The project is sponsored by

Canonical Ltd. [http://www.canonical.com], a holding company founded by Mark

http://www.gnome.org/
http://www.gnome.org/
http://www.kde.org/
http://www.kde.org/
http://www.kubuntu.org
http://www.kubuntu.org
http://www.canonical.com
http://www.canonical.com


Getting Started

13

Shuttleworth. Canonical employs the core Ubuntu developers and offers support and

consulting services for Ubuntu.

Canonical Ltd also sponsors a number of other Open Source software projects, about which

more information can be found on the Canonical website [http://www.canonical.com].

1.8. What is Linux?

The Linux kernel [http://www.kernel.org], pronounced 'lee-nucks' is the heart of the

Ubuntu operating system. A kernel is an important part of any operating system, providing

the communication bridge between hardware and software.

Linux was brought to life in 1991 by a Finnish student named Linus Torvalds. At the time,

it would run only on i386 systems, and was essentially an independently created clone of

the UNIX kernel, intended to take advantage of the then-new i386 architecture.

Nowadays, thanks to a substantial amount of development effort by people all around the

world, Linux runs on virtually every modern architecture.

The Linux kernel has gained an ideological importance as well as a technical one. There is

an entire community of people who believe in the ideals of free software and spend their

time helping to make open source technology as good as it can be.

People in this community gave rise to initiatives such as Ubuntu, standards committees

that shape the development of the Internet, organizations like the Mozilla Foundation,

responsible for creating Mozilla Firefox, and countless other software projects from which

you've certainly benefited in the past.

The spirit of open source, commonly attributed to Linux, is influencing software

developers and users everywhere to drive communities with common goals.

1.9. What is GNU?

The GNU Project, pronounced “guh-noo”, was launched in 1984 to develop a complete

UNIX style operating system which is comprised of free software: the GNU system.

Variants of the GNU operating system, which use the Linux kernel, are now widely used;

though these systems are often referred to as “Linux,” they are more accurately called

GNU/Linux systems.

The GNU project is closely linked to the philosophy of free software, which is central to

the projects that derive from it, such as Ubuntu. The concept of free software is explained

at Section 1.2, “Free Software” [p. 11] .

http://www.canonical.com
http://www.canonical.com
http://www.kernel.org
http://www.kernel.org
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2. Getting Ubuntu

There are a number of methods you may use to obtain a copy of Ubuntu, all of which are

described on the Ubuntu Web site download page [http://www.ubuntu.com/download].

The first method is to download an ISO image from a mirror server near you and make a

CD to install Ubuntu. Two types of CDs are available:

• Desktop CD - the desktop CD allows you to try Ubuntu without changing your computer

at all, and at your option to install it permanently later. This type of CD is what most

people will want to use.

• Text-mode install CD - the text-mode install CD allows you to perform certain

specialist installations of Ubuntu. This type of CD is intended for cases such as creating

pre-configured OEM systems or setting up automated deployments; it can also be used

as a package source for upgrading older installations.

If you don't have a CD burner or you have limited or expensive bandwidth, we can send

you pressed copies of the 'Desktop CD' free of charge. You may request CDs via Shipit

[http://shipit.ubuntu.com], the Ubuntu CD Distribution System.

Ordered CDs may take several weeks to arrive.

You can also contact an Ubuntu Local Community Team (LoCoTeam) near you.

These are self-organized groups of Ubuntu enthusiasts who want to bring the Ubuntu

community onto a local level. Most LoCoTeams have extra copies of Ubuntu and give

them out freely. A list of existing Ubuntu LoCoTeams can be found on the Ubuntu wiki

[https://wiki.ubuntu.com/LoCoTeamList].

Another method of obtaining Ubuntu is to join a local Linux Users Group (LUG) and ask if

somebody can make you a copy. Normally, you will have to pay for the cost of the CD and

delivery.

If you do not know of an LUG near you, a list can be found at Linux Users Groups

WorldWide [http://lugww.counter.li.org/].

http://www.ubuntu.com/download
http://www.ubuntu.com/download
http://shipit.ubuntu.com
http://shipit.ubuntu.com
https://wiki.ubuntu.com/LoCoTeamList
https://wiki.ubuntu.com/LoCoTeamList
http://lugww.counter.li.org/
http://lugww.counter.li.org/
http://lugww.counter.li.org/
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3. Linux Basics

Linux is inspired by the Unix operating system which first appeared in 1969, and has been

in continous use and development ever since. Many of the design conventions behind Unix

also exist in Linux and are central to understanding the basics of the system.

Unix was primarily oriented towards the command line interface, and that legacy is carried

on in Linux. Thus, the graphical user interface with its windows, icons and menus are

built on top of a basic command line interface. Furthermore, this means that the Linux file

system is structured to be easily manageable and accessible from the command line.

3.1. Directories and File Systems

Linux and Unix file systems are organised in a hierarchical, tree-like structure. The highest

level of the file system is the / or root directory. In the Unix and Linux design philosophy,

everything is considered a file - including hard disks, partitions and removable media. This

means that all other files and directories (including other disks and partitions) exist under

the root directory.

For example, /home/jebediah/cheeses.odt shows the correct full path to the

cheeses.odt file that exists in the jebediah directory which is under the home directory,

which in turn, is under the root (/) directory.

Underneath the root (/) directory, there is a set of important system directories that are

common across most Linux distributions that are used. The following is a listing of

common directories that are directly under the root (/) directory:

• /bin - important binary applications

• /boot - boot configuration files

• /dev - the device files

• /etc - configuration files, startup scripts, etc...

• /home - local users' home directories

• /lib - system libraries

• /lost+found - provides a lost+found system for files that exist under the root (/)

directory

• /media - mounted (loaded) removable media such as CDs, digital cameras, etc...

• /mnt - mounted filesystems

• /opt - provides a location for optional applications to be installed

• /proc - special dynamic directory that maintains information about the state of the

system, including currently running processes

• /root - root user home directory, pronounced 'slash-root'
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• /sbin - important system binaries

• /sys - system files

• /tmp - temporary files

• /usr - applications and files that are mostly available for all users to access

• /var - variable files such as logs and databases

3.2. Permissions

All of the files on a Linux system have permissions that allow or prevent others from

viewing, modifying or executing. The super user "root" has the ability to access any file

on the system. Each file has access restrictions, user restrictions and have an owner/group

association.

Every file is secured by the following three sets of permissions, in order of importance:

• user

applies to the user who is the owner of the file

• group

applies to the group that is associated with the file

• other

applies to all other users

Inside each of the three sets of permissions are the actual permissons. The permissions,

along with the way they apply differently to files and directories, are outlined below:

• read

files can be displayed/opened

directory contents can be displayed

• write

files can be edited or deleted

directory contents can be modified

• execute

executable files can be run as a program

directories can be entered

To view and edit the permissions on files and directories, open the Places → Home Folder

and right-click on a file or directory. Then select Properties. The permissions exist under



Getting Started

17

the Permissions tab and allow for the editing of all permission levels, if you are the owner

of the file.

To learn more about file permissions in Linux, read the file permissions page

[https://wiki.ubuntu.com/FilePermissions] in the Ubuntu Wiki.

3.3. Root And Sudo

The root user in GNU/Linux is the user which has administrative access to your system.

Normal users do not have this access for security reasons. However, Ubuntu does not

include the root user. Instead, administrative access is given to individual users, who

may use the "sudo" application to perform administrative tasks. The first user account

you created on your system during installation will, by default, have access to sudo. You

can restrict and enable sudo access to users with the Users and Groups application (see

Section 3.6, “Users and Groups” [p. 19]  for more information).

When you run an application that requires root privileges, sudo will ask you to input your

normal user password. This ensures that rogue applications cannot damage your system,

and serves as a reminder that you are about to perform administrative actions which require

you to be careful!

To use sudo when using the command line, simply type "sudo" before the command you

wish to run. Sudo will then prompt you for your password.

Sudo will remember your password for a set amount of time. This feature was designed to

allow users to perform multiple administrative tasks without being asked for a password

each time.

Be careful when doing administrative tasks, you might damage your system!

Some other tips on using sudo:

• To use a "root" terminal, type "sudo -i" at the command line.

• All of the default graphical configuration tools in Ubuntu already use sudo, so they will

prompt you for your password if needed.

• For more information on the sudo program and the absence of a root user in Ubuntu,

read the sudo page [https://wiki.ubuntu.com/RootSudo] on the Ubuntu wiki.

3.4. Terminals

Working at the command line is not as daunting a task as you would think. There is no

special knowledge needed to know how to use the command line, it is a program like

everything else. Most things in Linux can be done using the command line, although there

https://wiki.ubuntu.com/FilePermissions
https://wiki.ubuntu.com/FilePermissions
https://wiki.ubuntu.com/RootSudo
https://wiki.ubuntu.com/RootSudo
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are graphical tools for most programs, sometimes they are just not enough. This is where

the command line comes in handy.

The terminal is often called the command prompt or the shell. In days gone by, this was the

way the user interacted with the computer, however Linux users have found that the use of

the shell can be quicker than a graphical method and still holds some merit today. Here you

will learn how to use the terminal.

The original use of the terminal was a file browser and indeed it is still used as a file

browser, in the event of the graphical environment failing. You can use the terminal as a

file browser to navigate your files and undo the changes that have been made.

3.4.1. Starting the Terminal

To start Terminal choose Applications → Accessories → Terminal .

3.4.2. Common Commands

View Directories: - ls

The ls (LiSt) lists files in different colors with full formatted text

Create Directories: - mkdir (directory name)

The mkdir (MaKeDIRectory) command will create a directory.

Change Directories: - cd (/directory/location)

The cd (ChangeDirectory) command will change from your current directory to any

directory you specify.

Copy Files/Directories: - cp (file or directory name) (to directory or filename)

The cp (CoPy) command will copy any files you specify. The cp -r command will copy

any directories you specify.

Remove Files/Directories: - rm (file or directory name)

The rm (ReMove) command will delete any filename you specify. The rm -rf

command will remove any directory you specify.

Rename Files/Directories: - mv (file or directory name)

The mv (MoVe) command will rename/move any file or directory you specify.

Find Files/Directories: - locate (file or directory name)

The locate command will search your computer for any filename you specify. It uses

an index of the files on your system to work quickly: to update this index run the

command updatedb. This command is run automatically each day, if you leave your

computer on. It needs to be run with administrative privileges (see Section 3.3, “Root

And Sudo” [p. 17] ).

You can also use wildcards to match one or more files, such as "*" (for all files) or "?" (to

match one character).

For a more thorough introduction to the Linux command line, please read the command

line introduction [https://wiki.ubuntu.com/BasicCommands] on the Ubuntu wiki.

https://wiki.ubuntu.com/BasicCommands
https://wiki.ubuntu.com/BasicCommands
https://wiki.ubuntu.com/BasicCommands
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3.4.3. Switch to Console mode

The usual method of command-line access in Ubuntu is to start a terminal (see

Section 3.4.1, “Starting the Terminal” [p. 18]  above) , however sometimes it is useful

to switch to the real console:

1. Use the Ctrl-Alt-F1 shortcut keys to switch to the first console.

2. To switch back to Desktop mode, use the Ctrl-Alt-F7 shortcut keys.

There are six consoles available. Each one is accessible with the shortcut keys

Ctrl-Alt-F1 to Ctrl-Alt-F6.

3.4.4. Disable the beep sound in Terminal mode

1. Start a Terminal session, select: Applications → Accessories → Terminal from the

desktop menu system.

2. Edit → Current Profile... . Select the General tab. Uncheck the Terminal bell

checkbox.

3.5. Text Editing

All of the configurations and settings in Linux are saved in text files. Even though you

most often can edit configurations through the graphical interface, you may occasionally

have to edit them by hand. Gedit is the default Ubuntu text editor, which you can launch by

clicking Applications → Accessories → Text Editor on the desktop menu system.

At times in this guide, Gedit is run from the command line using gksudo, which runs Gedit

with administrative privileges, in order to modify configuration files.

If you need to use a text editor from the command line, you can use nano, which is

a simple to use text editor. When running it from the command line, always use the

following command, which ensures that the editor will not introduce line breaks:

nano -w

For more information about how to use nano, refer to the guide on the wiki

[https://wiki.ubuntu.com/NanoHowto].

There are also quite a few other terminal-based editors available in Ubuntu, popular ones

include VIM and Emacs (the pros and cons of each are cause for much friendly debate

within the Linux community). These are often more complex to use than nano, but are also

more powerful.

3.6. Users and Groups

To add users or groups to your system, you can use the Users And Groups application

located in System → Administration → Users and Groups .

https://wiki.ubuntu.com/NanoHowto
https://wiki.ubuntu.com/NanoHowto
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To add a new user, click on Add user, fill-in the data fields then click OK. To edit the

properties of each user, click the Properties button located in the main Users window.

To add a new group, select the Groups tab and click Add group. Choose a name for the

new group and, if you want, change the default value for the Group ID. If you try to

allocate a Group ID that is in use, the system will warn you.

You can add users to the newly created group by selecting a user from the left menu and

clicking on the Add button. Removing a user is as simple as adding one: select a user from

the right menu then click Remove. When you are ready, click OK and the new group with

its users, if inserted, will be created.

To edit the properties of a group, from within the Groups main window, choose a group

name and click on the Properties button.

To remove a user or a group from the system, select the user or group you want to delete

and click Delete.
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Chapter 2. Adding, Removing and

Updating Applications
This chapter is a complete guide to adding, removing and updating applications on an

Ubuntu system.
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1. Introduction

In order to add or remove applications in Ubuntu you need to use a package manager.

A package manager is a tool that makes installing and uninstalling applications easy

by handling the software in preconfigured packages that are optimized for Ubuntu. The

following package managers are described in this chapter:

• Add/Remove Applications - this is the simplest way to manage programs.

• Synaptic - this graphical program provides a more advanced means of managing

programs.

• APT - this is a powerful command line program to manage programs.

You may also wish to increase the number of programs available to install through your

package managers. Not all the programs that exist for Ubuntu are available by default. You

may have to add extra repositories in order to make them available: that is also described in

this chapter.

Finally, this chapter explains how to update your system.

You can only have one package management application running at a time.

For example, if you are running Add/Remove Applications and try to launch

Update Ubuntu, it will fail with an error. Close the running application before

you relaunch the new one.
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2. Add/Remove Applications

Add/Remove Applications is a simple graphical way of installing and removing

applications in Ubuntu. To launch Add/Remove Applications click Applications →
Add/Remove Applications on the desktop menu system.

Running Add/Remove Applications requires administrative privileges (see

Section 3.3, “Root And Sudo” [p. 17]).

To install new applications select the category on the left, then check the box of the

application you want to install. When finished click Apply, then your chosen programs will

be downloaded and installed automatically, as well as installing any additional applications

that are required.

Alternatively, if you know the name of the program you want, use the Search tool at the

top.

If you have not activated the online package archive, you may be asked to insert

your Ubuntu CD-ROM to install some packages.

Some applications and packages are not available to install using Add/Remove

Applications. If you cannot find the package you are looking for, click Advanced which

will open the Synaptic package manager (see below).
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3. Synaptic Package Manager

Synaptic is an advanced package management application that can install and remove

every package available to your system. The interface is graphical like Add/Remove

Applications but a lot more information is presented to the user, which means that Synaptic

gives you complete control over the package management of your system.

Running Synaptic requires administrative privileges (see Section 3.3, “Root And

Sudo” [p. 17]).

To launch Synaptic, choose System → Administration → Synaptic Package Manager on

the desktop menu system.

The Synaptic screen is divided up into four sections, the two most important being the

package categories on the left side, and the packages on the right.

To install packages, just choose the category, find the package name in the list, right click

on it and choose "Mark this package for installation". Once you are satisfied with your

selections click Apply on the top button bar. Synaptic will then download and install the

required packages from the online repositories and/or from your Ubuntu installation CD.

Alternatively you can click the Search tool bar button, enter the package name or a short

search term in the search text field and click the Search button.

Synaptic will now show you a much shorter list from which to select your application for

installation. This is usually much easier than having to look through the very long list of

applications on your own.
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4. Command Line Package Management

4.1. APT

APT (Advanced Packaging Tool) is a powerful package management system, on which

the graphical programs described above like Add/Remove Applications and Synaptic are

based. APT automatically handles dependencies and performs other operations on system

packages to allow the installation of the desired package/s.

Running APT requires administrative privileges (see Section 3.3, “Root And

Sudo” [p. 17]).

Some common commands that can be used with APT:

• Install packages:

sudo apt-get install packagename

• Remove packages:

sudo apt-get remove packagename

• Retrieve new lists of packages:

sudo apt-get update

• Upgrade system with available updates:

sudo apt-get upgrade

• List further commands and options:

apt-get help

For further information about the use of APT, read the comprehensive Debian

APT User Manual [http://www.debian.org/doc/user-manuals#apt-howto].

http://www.debian.org/doc/user-manuals#apt-howto
http://www.debian.org/doc/user-manuals#apt-howto
http://www.debian.org/doc/user-manuals#apt-howto
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5. Installing a Single Package File

The preferred method of installing programs is via the package managers described in this

chapter. However, although the Ubuntu package archives are very large, it is possible that

you may wish to install a package which is not available in the Ubuntu archives. If this

happens, you can also download and install files from websites.

It is important to ensure that any files you download come from a safe source

before installing them.

There are many different kinds of Linux package files. Most of these are associated with

the package managers of specific Linux distributions. Examples are Debian Package files

(.deb files), Redhat Package Manager files (.rpm files), and Tarballs (.tar files).

This section deals with installing these single files.

It is not guaranteed that these files will be compatible with your system and you

will not receive security updates if you install these files. For these reasons, if you

wish to install a program, always use a native Ubuntu package of the application

available through a package manager, if there is one available.

5.1. Install/uninstall .deb files

These files are Debian packages. The package files associated with Ubuntu have the .deb

suffix because of Ubuntu's close relations with the Debian GNU/Linux distribution. You

will need administrative privileges to install a .deb file (see Section 3.3, “Root And Sudo”

[p. 17]).

1. To install a .deb file, simply double click on it, and then select Install Package

2. Alternatively, you can also install a .deb file by opening a terminal and typing:

sudo dpkg -i package_file.deb

3. To uninstall a .deb file, deselect it in your package manager, or type:

sudo dpkg -r package_name

5.2. Convert .rpm files to .deb files

Another type of package files is Red Hat Package Manager files which have the .rpm

suffix. It is not recommended to install these on an Ubuntu system. In almost all cases, a

native Ubuntu .deb package is available. However, if absolutely necessary, an .rpm file can

be converted to a .deb package using the program alien.

1. Install the alien program (Chapter 2, Adding, Removing and Updating Applications

[p. 21]).

2. Run the following command in a terminal, with administrative privileges:
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sudo alien package_file.rpm

5.3. Install tarballs

Files with the .tar.gz or .tar.bz2 suffix are package files known as tarballs which are

widely used in Linux and Unix.

If there is no native Ubuntu package available in any of the Ubuntu repositories, you can

use the command line to install or uninstall the Tarball file by following the instructions

that come with the package.

Tarballs often contain the source code of the program, and need to be compiled in order

to be used. To do this, extra software will generally be needed (see Section 8.1, “Basic

Compilers” [p. 48] ).
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6. Extra Repositories

6.1. What are Repositories?

There are thousands of programs available to install on Ubuntu. These programs are stored

in software archives (repositories) and are made freely available for installation over the

Internet. This makes it very easy to install new programs in Linux, and it is also very

secure, because each program you install is built specially for Ubuntu and checked before

it is installed. To organise the software, Ubuntu repositories are categorised into four

groups: Main, Restricted, Universe, and Multiverse.

The rationale used to determine which software goes into which category is based on two

factors:

• The level of support software development teams provide for a program.

• The level of compliance the program has to the Free Software Philosophy

[http://www.ubuntu.com/ubuntu/philosophy].

You can find more information about the Repositories available on the website

[http://www.ubuntu.com/ubuntu/components].

The standard Ubuntu Install CD contains some software from the Main and Restricted

categories. Once your system is made aware of the Internet-based locations for these

repositories, many more software programs are made available for installation. Using the

software package management tools already installed on your system, you can search for,

install and update any piece of software directly over the Internet, without the need for the

CD.

6.2. Adding Extra Repositories

To enable the extra repositories:

1. Open System → Administration → Software Properties .

2. Select Add

3. To enable the Universe repository, check the Community Maintained (Universe)

button.

Adding this repository will mean that the majority of the Free Software

universe will be available to install on your system. This software is

supported by a carefully selected group of volunteers within the Ubuntu

Community, but is not supported by the core Ubuntu development team and

may not include security updates.

4. To enable the Multiverse repository, check the Non-free (Multiverse) button.

http://www.ubuntu.com/ubuntu/philosophy
http://www.ubuntu.com/ubuntu/philosophy
http://www.ubuntu.com/ubuntu/components
http://www.ubuntu.com/ubuntu/components
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Adding this repository will mean that software which has been classified as

non-free will be available to install on your system. This software may not

be permitted in some jurisdictions. When installing each package from this

repository, you should verify that the laws of your country permit you to use

it. Again, this software may not include security updates.

5. Click Close to save your changes and exit.

6. To apply your changes, select Reload.
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7. Updates

Sometimes the Ubuntu developers release feature and security updates for applications and

packages within the Ubuntu system.

When these updates are available, Ubuntu will inform you with a pop-up and a red icon in

your notification area. To update your system, click the red button, enter your password

and click OK.

The Update Manager program will list the available updates: to download and install these

updates click Install Updates. Ubuntu will then download and install the available updates

from the Internet.

When Update Manager has finished updating your system, close the pop-up window with

the Close button, then close Update Manager to finish updating your system.

After installing some important updates, it may be necessary to restart your

computer. If so, Ubuntu will inform you with a popup and an icon in your

notification area.
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Chapter 3. Common Tasks
This chapter contains information on common tasks.
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1. Music

1.1. Playing and Extracting Audio CDs

When you insert an audio CD, the Sound Juicer CD player and ripper opens automatically.

To play the CD, click the Play button or press Ctrl-P. To play a particular track,

double-click on the track or select the track and click Play.

To extract (rip) your audio CD, make sure the tracks that you want to rip are selected, then

click the Extract button or press Ctrl-Enter.

If you are connected to the internet, Sound Juicer will retrieve the CD

artist, title, and track data from MusicBrainz.org [http://musicbrainz.org], a

community-maintained database which contains data on over 360,000 albums.

To start Sound Juicer manually, choose Applications → Sound & Video → Sound Juicer

CD Extractor.

You can use the preferences window to control where the extracted audio files are stored

on your computer, the filename of extracted audio files, and the file format and codec used

for the files. In the main window, choose Edit → Preferences.

Sound Juicer can extract audio files to the following formats:

• Ogg Vorbis - Ogg Vorbis is a patent-free lossy audio compression format which

typically produces higher quality and greater compression than MP3. See the Vorbis

website [http://www.vorbis.com/faq/] for more information.

• FLAC - FLAC is the Free Lossless Audio Codec. It can compress audio files up to 50%

without removing any information from the audio stream. For more information on this

format, see the FLAC homepage [http://flac.sourceforge.net/] on sourceforge.net.

• WAV - Use the WAV format for voice recordings. Sound Juicer uses this format for low

quality mono audio files.

You can also extract CD audio files to the proprietary non-free MP3 format. Instructions

on how to rip to the MP3 format are in the help for Sound Juicer. Choose Help → Contents

and navigate to the Preferences section.

1.2. Burning CDs

When you put a blank CD in the drive Ubuntu will ask if you want to burn an audio or

data CD. Clicking on Burn Audio CD will launch Serpentine . To add music to your audio

CD, either drag music from your File Browser or use the Add button. You will also need

to select the size of your CD (21, 74, 80 or 90 minutes). Serpentine will warn you if you

exceed the set limit.

http://musicbrainz.org
http://musicbrainz.org
http://www.vorbis.com/faq/
http://www.vorbis.com/faq/
http://www.vorbis.com/faq/
http://flac.sourceforge.net/
http://flac.sourceforge.net/
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To make a photo or data CD, click the burn Burn Data CD. Ubuntu will open a CD/DVD

Creator window. The CD Creator is built into the File Browser, and it allows you to add

any file or folder you have permission to access. When you are ready to burn the CD, click

Write to Disc. Ubuntu will then prompt you to select the drive containing the blank CD,

and give you the opportunity to name the CD and select the write speed. Finally, click

Write to create the new photo or data CD.

1.3. Playing and Organising Music Files

To play and organize your music, Ubuntu comes with#Rhythmbox Music Player, which

looks similar to iTunes. When you first start Rhythmbox, it will scan your home directory

for any supported music files you have and add it to the database. To start Rhythmbox,

choose Applications → Sound & Video → Rhythmbox Music Player

Ubuntu does not directly support the MP3 format, because it is restricted by patents and

proprietary rights. Instead Ubuntu supports the Ogg Vorbis format out of the box, a

completely free, open and non-patented format. Ogg Vorbis files also sound better then

MP3 files of the same file size and are supported by many popular music players (a list of

players is here [http://wiki.xiph.org/index.php/PortablePlayers]).

You can still play your old MP3 files by installing MP3 support (see Section 3,

“Multimedia Codecs” [p. 38] ). Instructions for other formats, such as Windows Media

Audio (wma/wmv) and other patent encumbered formats can be found on the Ubuntu Wiki

[http://wiki.ubuntu.com/RestrictedFormats].

The Cowbell ID3 tag editor can edit the metadata on your mp3 and other music files. To

use Cowbell:

1. Install the cowbell package from the Universe repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]);

2. To run Cowbell, choose Applications → Sound & Video → Cowbell Music

Organizer.

1.4. Using your Ipod

You can play music directly off your IPOD with Rhythmbox Music Player. Simply plug

your IPOD into the computer, and open Rhythmbox.

To transfer music files to and from an IPOD, you can use the program gtkpod:

1. Install the gtkpod package from the Universe repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

2. To run gtkpod, choose Applications → Sound & Video → gtkpod.

http://wiki.xiph.org/index.php/PortablePlayers
http://wiki.xiph.org/index.php/PortablePlayers
http://wiki.ubuntu.com/RestrictedFormats
http://wiki.ubuntu.com/RestrictedFormats
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1.5. Editing Audio Files

Audacity is free, open source software for recording and editing sounds. To use Audacity:

1. Install the audacity package from the Universe repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

2. To run Audacity, choose Applications → Sound & Video → Audacity.

3. For further help about using Audacity, consult the program's help by choosing Help

→ Contents.
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2. Video

To play video, Ubuntu comes with Totem Movie Player which looks and functions

similar to Windows Media Player. Some features of Totem include custom playlists, DVD

playback and more. You can start Totem by clicking: Applications → Sound & Video →
Movie Player from the desktop menu system.

To read video files, Totem uses the Gstreamer framework. To play some video formats,

you may need to add further codec support (see Section 3, “Multimedia Codecs” [p.

38] ).

There are also other multimedia applications available. Examples include Mplayer, Xine

and Totem-xine (which uses the Xine framework, instead of the Gstreamer framework.

Some users may benefit from trying alternative video players.

2.1. DVD Playback

The movie players provided in Ubuntu are capable of reading DVDs that are not encrypted.

However, most commercial DVDs are encrypted with CSS (the Content Scrambling

System) and currently for legal reasons it is not possible to include support for these DVDs

in Ubuntu. However it is possible to enable support as follows:

The legal status of this library is not fully clear. In some countries it is possible

that the use of this library to play or copy DVDs is not permitted by law. Verify

that you are within your rights in using it.

1. Install the libdvdread3 package (see Chapter 2, Adding, Removing and Updating

Applications [p. 21]).

You will need to use Synaptic Package Manager to install this package

2. To activate DVD decryption, type the following line into a terminal prompt:

sudo /usr/share/doc/libdvdread3/examples/install-css.sh

3. To play DVDs with Totem, you will need to install some extra codecs (see Section 3,

“Multimedia Codecs” [p. 38] ).

4. However, the Gstreamer framework (used by Totem) does not support menus or

subtitles for DVD playback. For this reason, you can install a separate DVD player,

Xine, which supports these. To install Xine, install the gxine package from the

Universe repository (see Chapter 2, Adding, Removing and Updating Applications [p.

21]).

5. You can then open gxine from the Sound & Video menu.
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2.2. Backing Up DVDs

Backing up your DVDs to files or onto DVD+/- discs can be done with DVD::RIP. To

install DVD::RIP:

Before backing up a DVD, you must ensure that you are legally permitted to

make copies of it.

1. Install the Multimedia Codecs (see Section 3, “Multimedia Codecs” [p. 38] ).

2. Enable DVD video playback (see Section 2.1, “DVD Playback” [p. 35] ).

3. Install dvdrip and transcode from the Multiverse repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

4. You can run the program using the command dvdrip (see Section 1.2, “Start

a Program Manually” [p. 51] ). If you wish, you can add a menu entry

for the program dvdrip (see Section 1.1, “Menu Editing” [p. 51] ). We

recommend you enter it in the Sound & Video menu, and that you use the file

/usr/share/perl5/Video/DVDRip/icon.xpm for the icon.

5. To start dvd::rip, choose Applications → Sound & Video → dvd::rip.

2.3. RealPlayer 10

1. Install the libstdc++5 package (see Chapter 2, Adding, Removing and Updating

Applications [p. 21]).

You will need to use Synaptic Package Manager to install this package

2. Download the Realplayer package from here [ftp://ftp.nerim.net/debian-marillat/pool/

main/r/realplay/realplayer_10.0.6-0.0_i386.deb].

3. Install the package you have downloaded (see Section 5.1, “Install/uninstall .deb

files” [p. 26]).

4. To run Real Player 10, choose Applications → Sound & Video → RealPlayer 10.

2.4. Video Editing

Kino is an advanced video editor. It features excellent integration with IEEE-1394 for

capture, VTR control, and recording back to the camera. It captures video to disk in Raw

DV and AVI format, in both type-1 DV and type-2 DV (separate audio stream) encodings.

For more information, see the Kino website [http://www.kinodv.org/article/static/2]. To use

it:

1. Install the kino package (see Chapter 2, Adding, Removing and Updating Applications

[p. 21]).

2. To run Kino, choose Applications → Sound & Video → Kino Video Editor.

ftp://ftp.nerim.net/debian-marillat/pool/main/r/realplay/realplayer_10.0.6-0.0_i386.deb
ftp://ftp.nerim.net/debian-marillat/pool/main/r/realplay/realplayer_10.0.6-0.0_i386.deb
ftp://ftp.nerim.net/debian-marillat/pool/main/r/realplay/realplayer_10.0.6-0.0_i386.deb
http://www.kinodv.org/article/static/2
http://www.kinodv.org/article/static/2
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You can also try the PiTiVi video editor by installing the pitivi package from the Universe

repository (see Chapter 2, Adding, Removing and Updating Applications [p. 21]). PiTiVi

is a video editor for the GNOME desktop. It is still in fairly early development, but worth a

try.



Common Tasks

38

3. Multimedia Codecs

Many applications in Ubuntu use the GStreamer open source multimedia

framework. The codec plugins for GStreamer are organised in different

packages depending on the licensing that applies to the various codecs. You

can see which codecs are contained in which plugin on the GStreamer website

[http://gstreamer.freedesktop.org/documentation/plugins.html].

Other applications, such as Mplayer and Xine, do not use the Gstreamer framework.

Due to patent and copyright restrictions, codecs for these programs are not included

at all in Ubuntu. For more information on these read the Restricted Formats

[https://wiki.ubuntu.com/RestrictedFormats] wiki page.

3.1. Add Codecs to Gstreamer

To install extra codecs for Gstreamer:

• Install the following packages from the Universe and Multiverse repositories (see

Chapter 2, Adding, Removing and Updating Applications [p. 21]):

gstreamer0.10-plugins-ugly

gstreamer0.10-plugins-ugly-multiverse

gstreamer0.10-plugins-bad

gstreamer0.10-plugins-bad-multiverse

gstreamer0.10-ffmpeg

        

You will need to use Synaptic Package Manager to install these packages

Some of these packages may not be permitted in some countries: you should

verify that you are permitted to use them before installing them.

http://gstreamer.freedesktop.org/documentation/plugins.html
http://gstreamer.freedesktop.org/documentation/plugins.html
https://wiki.ubuntu.com/RestrictedFormats
https://wiki.ubuntu.com/RestrictedFormats


Common Tasks

39

4. Internet

4.1. Connecting to the Internet

To connect to the internet, do the following:

1. If you have a Modem or ADSL connection, read Section 3.5, “Modems” [p. 62]

first.

2. System → Administration → Networking

3. Select the Connections tab. Select the Ethernet connection interface from the list,

then click the Properties button. Ensure that the button marked Enable this connection

is checked. From the Configuration drop-list select DHCP/Static IP address, then

click OK.

4. Select the DNS tab add or delete DNS Servers in the DNS Servers list.

To activate or deactivate network connections, do the following:

1. System → Administration → Networking

2. Select Network settings+Connections Tab+Ethernet connection

Activate/Deactivate

4.2. Browse Network Computers

1. To view computers on the network, open:

Places → Network Servers

2. You may need to enter a username and password, and a domain. You should obtain

these from your network administrator.

3. A list of network resources will be displayed.

4.3. Email

The Evolution groupware suite can handle all your email, contact lists, tasks and calendar

needs. It also can act as a newsreader and also integrates with the Gnome panel clock,

giving you one-click access to your task list.

Evolution can be launched by clicking Applications → Internet → Evolution Mail from the

desktop menu system.

Alternatively the Mozilla Thunderbird email client is available. To install this popular

email client, install the mozilla-thunderbird package (see Chapter 2, Adding, Removing

and Updating Applications [p. 21]).

To start Thunderbird, choose Applications → Internet → Thunderbird Mail Client from the

desktop menu system.
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4.4. World Wide Web

The powerful and secure Mozilla Firefox web browser is included in Ubuntu. Firefox

features tabbed browsing, pop-up blocking, in-built search facilities, live bookmarks and

more. Also supported are popular plug-ins such as Java, Macromedia Flash, and Real

Player. Firefox can be launched by clicking Applications → Internet → Firefox from the

desktop menu system.

4.4.1. Viewing Online Audio and Video in Firefox

In order to view online audio and video streams in Firefox, you may need to install some

plugins. Which plugin you choose to install depends on the media player which you prefer

(see Section 2, “Video” [p. 35]).

1. For the Totem Gstreamer plugin (the default Ubuntu media player), install the

totem-gstreamer-firefox-plugin package from the Universe repository (see Chapter 2,

Adding, Removing and Updating Applications [p. 21]).

2. For the Totem Xine plugin, install the totem-xine-firefox-plugin package from the

Universe repository (see Chapter 2, Adding, Removing and Updating Applications [p.

21]).

3. For the Mplayer plugin, install the mozilla-mplayer package from the Multiverse

repository (see Chapter 2, Adding, Removing and Updating Applications [p. 21]).

4. The changes will take effect when you close and open Firefox.

These steps will install the plugin for Firefox. However, to play some formats,

you may need to add some extra codecs (see Section 3, “Multimedia Codecs” [p.

38]).

4.4.2. Macromedia Flash for Firefox

To view flash graphics from the Mozilla Firefox web browser:

1. Install the flashplugin-nonfree package from the Multiverse repository (see Chapter 2,

Adding, Removing and Updating Applications [p. 21]).

2. To download and install the plugin, enter the following command in a terminal:

sudo update-flashplugin

3. The plug-in will be available the next time you start Firefox.

4.4.3. Java plugin for Mozilla Firefox

Some websites require the Java plugin for Mozilla Firefox. To install the java plugin,

install the sun-java5-plugin package (for i386 machines) or the j2re-1.4-mozilla-plugin

package (for amd64 machines) from the Multiverse repository.
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4.4.4. NVU Web Authoring System

NVU is a WYSIWYG (What You See Is What You Get) graphical web design application,

similar to Dreamweaver.

1. Install the nvu package from the Universe repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

2. To start Nvu, choose Applications → Programming → Nvu from the desktop menu

system.

4.4.5. Bluefish Web Development Studio

Bluefish is a powerful editor for web designers and programmers. Bluefish supports

many programming and markup languages, and includes many utilities for designers and

programmers.

1. Install the bluefish package from the Universe repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

2. To start Bluefish, choose Applications → Programming → Bluefish Editor

4.5. Instant Messaging

4.5.1. Gaim

Gaim is the default instant messenger client in Ubuntu. With Gaim you can talk to people

who use AIM/ICQ, Gadu-Gadu, GroupWise, IRC, Jabber, MSN, Napster and Yahoo. The

ability to use one client instead of several is a great benefit and allows you to have all of

your buddies in one window so you can just click a name and talk. To start Gaim, choose

Applications → Internet → Gaim Internet Messenger from the menu.

4.5.2. XChat-GNOME

XChat-GNOME is a advanced, graphical, multi-platform Internet Relay Chat (IRC) client.

Its features include advanced scripting support (perl and python) and a clean, easy to use

interface.

1. Install the xchat-gnome package from the main repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

2. To start XChat-GNOME, choose Applications → Internet → Xchat-GNOME IRC

Chat .

4.5.2.1. Joining #ubuntu with XChat-Gnome

One excellent way to get help with Ubuntu or introduce yourself to IRC is to join Ubuntu's

official support channel on Freenode.

1. Start XChat-Gnome as above.
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2. When you start XChat-Gnome for the first time, it will ask you for an IRC Nickname

& your real name. Pick anything you want for your nick (first initial & your last name

is good, or be more creative), put your real name or part of it, and press OK.

3. In the Server Window that opens next, select Ubuntu Servers, and press Connect.

4.6. Peer To Peer

4.6.1. BitTorrent

BitTorrent capability is included in Ubuntu by default. Find a BitTorrent .torrent file

online, click on it in Firefox, and the Gnome BitTorrent client should start automatically.

Alternatively, download a .torrent file and double click on it.

4.6.2. aMule File Sharing Client

1. Install the amule package from the Universe repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

2. To open aMule, choose Applications → Internet → aMule

4.7. News Readers

4.7.1. Pan News Reader

1. Install the pan package (see Chapter 2, Adding, Removing and Updating Applications

[p. 21]).

2. To open Pan Newsreader, choose Applications → Internet → Pan Newsreader.

4.7.2. Liferea News Reader

1. Install the liferea package from the Universe repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

2. To open Liferea Feed Reader, choose Applications → Internet → Liferea Feed

Reader.
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5. Office

5.1. Introduction

Ubuntu comes with a comprehensive office suite installed - OpenOffice.org. The

OpenOffice.org project is one of the most successful open source projects in the

world, and provides a powerful wordprocessor, spreadsheet, presentation designer and

database management, and provides support for most languages. The Suite has excellent

compatibility with other major Office suites, such as Microsoft Office.

For more information about OpenOffice.org, see the OpenOffice.org website

[http://www.openoffice.org/product/index.html].

However, you may wish to add extra programs to your system. This section outlines a

number of other useful office applications.

5.2. GNOME Office

The GNOME desktop features a separate office suite. These programs are generally lighter

and faster than the programs in the OpenOffice.org suite, and have fewer features as a

result. But this may be exactly what you want. The Suite has excellent compatibility with

other major Office suites, such as Microsoft Office.

The GNOME Office Suite includes the following software:

• A word processor (Abiword);

• A spreadsheet (Gnumeric);

• A database management program (GNOME-DB);

• A diagram editor (Dia);

• Two graphics applications (Inkscape and The GIMP); and

• A project management application (Planner).

Each of these applications can also be installed separately.

To install the GNOME Office suite:

1. Install the gnome-office package from the Universe repository (see Chapter 2,

Adding, Removing and Updating Applications [p. 21]).

2. The Office applications can then be found in the menu at Applications → Office, and

the Graphics applications can be found at Applications → Graphics.

5.3. GnuCash Accounting Application

GnuCash is a program to manage your personal or business finances. Designed to be easy

to use, yet powerful and flexible, GnuCash allows you to track bank accounts, stocks,

http://www.openoffice.org/product/index.html
http://www.openoffice.org/product/index.html
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income and expenses. As quick and intuitive to use as a checkbook register, it is based on

professional accounting principles to ensure balanced books and accurate reports.

To find out more about GnuCash, see the GnuCash website [http://www.gnucash.org/].

To use GnuCash:

1. Install the gnucash package from the Universe repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

2. You can open GnuCash by running the command gnucash (see Section 1.2, “Start

a Program Manually” [p. 51] ). If you wish, you can add a menu entry for the

program gnucash (see Section 1.1, “Menu Editing” [p. 51] ).

5.4. Scribus Desktop Publishing Application

Scribus is a professional desktop publishing program. For more information, see the

Scribus website [http://www.scribus.org.uk/].

1. Install the scribus package (see Chapter 2, Adding, Removing and Updating

Applications [p. 21]).

2. To install additional templates, install the scribus-template package from the Universe

repository (see Chapter 2, Adding, Removing and Updating Applications [p. 21]).

You will need to use Synaptic Package Manager to install this package

3. To start Scribus, choose Applications → Office → Scribus .

http://www.gnucash.org/
http://www.gnucash.org/
http://www.scribus.org.uk/
http://www.scribus.org.uk/
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6. Graphics & Drawing

Ubuntu has some very powerful, world-class graphics and drawing applications available.

6.1. gThumb Image Viewer

gThumb is an advanced image viewer and browser. It has many useful features, such

as filesystem browsing, slide show, image catalogs, web album creation, camera

import, image CD burning, batch file operations and quick image editing features like

transformation and color manipulation.

gThumb is included in Ubuntu by default. To start it, choose Applications → Graphics →
gThumb Image Viewer .

gThumb's excellent help files are accessible from Help → Contents.

For more advanced photo & image editing, see The GIMP, below.

6.2. The GIMP (Gnu Image Manipulation Program)

The GIMP lets you draw, paint, edit images, and much more! GIMP includes the

functionality and plug-ins of other famous image editing and processing programs.

The GIMP is installed in Ubuntu by default, and can be started by choosing Applications

→ Graphics → GIMP Image Editor .

More information is available from the GIMP homepage. [http://www.gimp.org/]

6.3. Inkscape Vector Graphics Editor

Inkscape is a powerful editor for working with the SVG (Scalable Vector Graphics) format.

1. Install the inkscape package (see Chapter 2, Adding, Removing and Updating

Applications [p. 21]).

2. To start Inkscape choose Applications → Graphics → Inkscape SVG Vector

Illustrator .

6.4. Blender 3d Modeller

Blender is an integrated 3d suite for modelling, animation, rendering, post-production,

interactive creation and playback.

1. Install the blender package (see Chapter 2, Adding, Removing and Updating

Applications [p. 21]).

2. To start Blender choose Applications → Graphics → Blender 3d modeller.

http://www.gimp.org/
http://www.gimp.org/
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7. Games

Ubuntu comes with a number of games by default, including Aisleriot Solitaire, Gnometris,

and Mines.

Explore Ubuntu's Games menu at Applications → Games .

7.1. Frozen-Bubble

In Frozen-Bubble you attempt to shoot bubbles into groups of the same color to cause them

to pop.

1. Install the frozen-bubble package from the Universe repository (see Chapter 2,

Adding, Removing and Updating Applications [p. 21]).

2. To start Frozen-Bubble, choose Applications → Games → Frozen-Bubble.

7.2. PlanetPenguin Racer

Race Tux, the Linux mascot, down a snow- and ice-covered mountain as quickly as

possible, avoiding the trees and rocks that will slow you down.

Ensure you have hardware accelerated 3D drivers installed for your video card.

For more information see Section 3, “Hardware” [p. 60] .

1. Install the planetpenguin-racer package from the Universe repository (see Chapter 2,

Adding, Removing and Updating Applications [p. 21]).

2. To start PlanetPenguin Racer, choose Applications → Games →
PlanetPenguin-Racer.

7.3. Scorched3D

Scorched3D is a 3D remake of Scorched Earth, an artillery duel game.

Ensure you have hardware accelerated 3D drivers installed for your video card.

For more information see Section 3, “Hardware” [p. 60] .

1. Install the scorched3d package from the Universe repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

2. To start Scorched3D, choose Applications → Games → scorched 3d.

7.4. Windows Games

Many games which are available for Windows can be run on Linux through emulators.

Examples of these are Wine and Cedega
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1. For information about Wine, see the Ubuntu wiki [https://wiki.ubuntu.com/Wine].

2. For information about Cedega, see the Ubuntu wiki [https://wiki.ubuntu.com/Cedega]

https://wiki.ubuntu.com/Wine
https://wiki.ubuntu.com/Wine
https://wiki.ubuntu.com/Cedega
https://wiki.ubuntu.com/Cedega


Common Tasks

48

8. Programming

8.1. Basic Compilers

1. In order to be able to compile programs, some extra packages are necessary. These

can be installed all at once, as follows:

2. Install the build-essential package (see Chapter 2, Adding, Removing and Updating

Applications [p. 21]).

8.2. Java (1.5)

The following instructions are only for i386 and amd64 computers. For PowerPC

machines, please look at the Ubuntu Wiki. [https://wiki.ubuntu.com/JavaPPC]

1. To install the Java Runtime Environment (to run java programs), install the

sun-java5-jre package from the Multiverse repository (see Section 6, “Extra

Repositories” [p. 28]).

2. To install the Java Development Kit (to compile java programs), install the

sun-java5-jdk package from the Multiverse repository (see Section 6, “Extra

Repositories” [p. 28]).

3. To choose which java installation you want to use, run:

sudo update-alternatives --config java

and pick the option which you prefer.

8.3. Development Tools

A list of handy open source development tools for use on Ubuntu such as Integrated

Development Environments (IDEs) and powerful editors.

• Anjuta [http://anjuta.sourceforge.net/] is an Integrated Development Environment (IDE)

for C and C++.

• Bazaar-NG [http://www.bazaar-ng.org/] is a decentralised version control system used

for Ubuntu development.

• Bluefish [http://bluefish.openoffice.nl/index.html] is a powerful editor for experienced

web designers and programmers.

• Eclipse [http://www.eclipse.org/] is an IDE for Java and other programming languages.

It forms the basis for closed-source programs such as JBuilder.

• Eric [http://www.die-offenbachs.de/detlev/eric3.html] is a fully featured Python and

Ruby IDE.

• Glade [http://glade.gnome.org/] is a User Interface designer for building GNOME

applications.

https://wiki.ubuntu.com/JavaPPC
https://wiki.ubuntu.com/JavaPPC
http://anjuta.sourceforge.net/
http://anjuta.sourceforge.net/
http://www.bazaar-ng.org/
http://www.bazaar-ng.org/
http://bluefish.openoffice.nl/index.html
http://bluefish.openoffice.nl/index.html
http://www.eclipse.org/
http://www.eclipse.org/
http://www.die-offenbachs.de/detlev/eric3.html
http://www.die-offenbachs.de/detlev/eric3.html
http://glade.gnome.org/
http://glade.gnome.org/
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• IDLE [http://www.python.org/idle/] is the Python IDE built with the Tkinter GUI

toolkit.

• KDevelop [http://www.kdevelop.org/] is a IDE for KDE which supports many

programming languages.

• MonoDevelop [http://www.monodevelop.com/Main_Page] is an IDE for writing

mono/.net applications in C# and other languages.

• NetBeans [http://www.netbeans.org/index.html] is a Java IDE that features support for

CVS and a form builder.

8.4. Programming Documentation

Some useful documentation for programming with Ubuntu.

8.4.1. Dive Into Python

Dive Into Python is a book on learning how to program in the preferred Ubuntu language,

Python. Aimed at programmers with some previous experience, it comes installed with

every Ubuntu installation.

You can read Dive Into Python here

[file:///usr/share/doc/diveintopython/html/toc/index.html].

8.4.2. PyGTK Tutorial

PyGTK Tutorial is a tutorial on developing with the graphical toolkit often used for

developing Ubuntu applications. It assumes that you have knowledge of Python but not

necessarily GTK.

1. Install the python-gtk2-tutorial package (see Chapter 2, Adding, Removing and

Updating Applications [p. 21]).

You will need to use Synaptic Package Manager to install this package

2. To access the documentation, visit python-gtk-tutorial

[file:///usr/share/doc/python-gtk2-tutorial/html/index.html].

8.4.3. Other Documentation

Devhelp is an application to read and search all of the documentation that you install.

1. Install the devhelp package (see Chapter 2, Adding, Removing and Updating

Applications [p. 21]).

2. Choose: Applications → Programming → Devhelp

http://www.python.org/idle/
http://www.python.org/idle/
http://www.kdevelop.org/
http://www.kdevelop.org/
http://www.monodevelop.com/Main_Page
http://www.monodevelop.com/Main_Page
http://www.netbeans.org/index.html
http://www.netbeans.org/index.html
file:///usr/share/doc/diveintopython/html/toc/index.html
file:///usr/share/doc/diveintopython/html/toc/index.html
file:///usr/share/doc/python-gtk2-tutorial/html/index.html
file:///usr/share/doc/python-gtk2-tutorial/html/index.html
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Chapter 4. Configuring Your System
This chapter contains information on configuring your system.



Configuring Your System

51

1. Desktop Tricks

This section details some tips for using and customising Ubuntu's desktop environment

(called GNOME), and the file manager (called Nautilus).

1.1. Menu Editing

Ubuntu comes with the Alacarte Menu Editor, so you can customize your menus and add

entries for applications that don't automatically appear after they are installed.

To add a new menu entry:

1. Open Alacarte with Applications → Accessories → Alacarte Menu Editor, or by

right-clicking on any top-level menu and choosing Edit Menus.

2. In Alacarte's left-hand pane, choose the submenu the new entry should appear in.

3. Choose File → New Entry. In the New Entry window, choose a Name, Comment,

Command and Icon. The Command will usually be the package name, Name is what

will appear on the menu, and the Comment will appear in the tooltip that appears near

the menu entry. Icons are added to the /usr/share/pixmaps directory by default, or

can be chosen from anywhere in your files.

To change the order of menu entries, use the up and down arrows on the right-hand side of

the Alacarte window.

To stop a menu entry from being displayed, use the checkboxes beside each entry. This

does not erase the menu entry, so you can restore it later in the same way.

1.2. Start a Program Manually

Sometimes it can be useful to start a program manually, for example when the program

does not have an entry in the menu. This is easy to do with the Run Applications dialogue.

For an application you intend to use regularly that does not have a menu entry, it is also

very easy to add a menu entry to Ubuntu. (see Section 1.1, “Menu Editing” [p. 51] )

1. Open the Run Applications dialogue by typing:#Alt-F2

2. Enter the name of the program you wish to run, and press Enter.

1.3. Run programs automatically when GNOME starts

1. Choose System → Preferences → Sessions .

2. Click on the Startup Programs tab.

3. Use the Add, Edit, and Delete buttons to manage programs to run at startup. Some

programs will automatically add themselves to this list when you configure them.
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1.4. Login automatically to GNOME when the computer starts

It is possible to login a user automatically when the computer boots. This is not

recommended for most computers, as it is not secure and may allow other users access to

your information

1. System → Administration → Login Screen Setup

2. Select the Security tab. Check the Enable Automatic Login checkbox option.

3. Choose the user you wish to be automatically logged in.

1.5. Change Display Mode in Nautilus

Ubuntu's file manager Nautilus provides two modes in which you can interact with your

filesystem: Spatial mode and Browser mode.

• In Browser mode, the file manager window represents a browser, which can display any

location. Opening a folder updates the current file manager window to show the contents

of the new folder.

• In Spatial mode, the file manager window represents a particular folder. Opening a

folder opens the new window for that folder. Each time you open a particular folder, you

will find its window displayed in the same place on the screen and the same size as the

last time you viewed it (this the reason for the name).

Browser mode is the default setting on Ubuntu, but you may wish to change this:

1. In Nautilus, choose Edit → Preferences.

2. Click on the Behavior tab.

3. Unselect the Always open in browser windows check box.

4. Close and reopen Nautilus.

1.6. Show hidden files and folders in Nautilus

1. In Nautilus, use the Ctrl-H shortcut keys to toggle hidden files and folders on and off,

or select View → Show Hidden Files.

2. To permanently show all hidden files and folders, choose Edit → Preferences.

3. Click on the Views tab.

4. Select the Show hidden and backup files check box.

1.7. Open the Location Bar in Nautilus

The Location Bar is the bar in your file manager in which you can type an address. Toggle

the bar on and off with: Go → Location... You can also use the Ctrl-L shortcut keys.
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1.8. View remote SSH, FTP, and SFTP servers using Nautilus

1. Make sure the Nautilus Location Bar is open (see Section 1.7, “Open the Location

Bar in Nautilus” [p. 52] ).

2. In the Location Bar, enter the following:

For SSH, use:

ssh://username@ssh.server.com

For FTP, use:

ftp://username@ftp.server.com

For SFTP, use:

sftp://username@sftp.server.com

Replace username with your username and replace everything after the @ symbol

with the server's address. You will be prompted for a password if needed. If there is

no username (anonymous) omit the username and the @ symbol.

Alternatively, to specify your password manually, change one of the above like so:

ftp://username:password@ftp.server.com

3. To access remote servers easily through Nautilus, add a permanent bookmark to the

server by selecting Places → Connect to Server... and entering the details for the

remote server.

1.9. Change the default "Open with" program for a file type

1. In Nautilus, right click on the file and choose Properties from the menu that appears.

The Properties dialog opens.

2. Click on the Open With tab. A list of applications appears.

3. Select the default application you want for the file type. If the application is not on the

list, use the Add button to add the application to the list.

1.10. Open files with administrative privileges from the file manager

To enable support for opening files with administrative privileges from the file manager,

you need to add a Nautilus script:

Please note that opening files with administrative privileges constitutes a security

risk. Always ensure that you are familiar with the file that you are opening.

1. Open a new file to edit in the relevant directory:

gedit $HOME/.gnome2/nautilus-scripts/Open\ as\ Administrator

2. Insert the following lines into the new file:
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for uri in $NAUTILUS_SCRIPT_SELECTED_URIS; do

gksudo "gnome-open $uri" &

done

3. Save the edited file (an example [../sample/nautilus_open_as_administrator])

4. Make the edited file executable:

chmod +x $HOME/.gnome2/nautilus-scripts/Open\ as\ Administrator

5. You can now open files as root by right clicking on the file and selecting Scripts →
Open as Administrator

1.11. Install Extra Fonts

This section describes how to install extra fonts from the Ubuntu archives.

1. For international fonts, install the following packages from the Universe repository

(see Chapter 2, Adding, Removing and Updating Applications [p. 21]):

xfonts-intl-arabic

xfonts-intl-asian

xfonts-intl-chinese

xfonts-intl-chinese-big

xfonts-intl-european

xfonts-intl-japanese 

xfonts-intl-japanese-big

xfonts-intl-phonetic

        

2. For Microsoft TrueType core fonts, install the msttcorefonts package from the

Multiverse repository (see Chapter 2, Adding, Removing and Updating Applications

[p. 21]).

3. For Ghostscript fonts, install the gsfonts-x11 package (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

4. After installing any new font, rebuild the font information files by typing the

following at a terminal prompt:

sudo fc-cache -f -v

If you prefer to download individual fonts by hand, you can install them simply and easily

by opening a file manager, and typing fonts:/// into the location bar (See Section 1.7,

“Open the Location Bar in Nautilus” [p. 52] ). Then you can simply drag the font you

downloaded into the group of existing fonts.

1.12. RAR Archiver

1. Install the rar package from the Multiverse repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

../sample/nautilus_open_as_administrator
../sample/nautilus_open_as_administrator
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2. Run:

sudo ln -fs /usr/bin/rar /usr/bin/unrar

3. To open a rar file, double click on it.

1.13. Advanced Desktop Applets

gDesklets is a system for bringing mini programs (desklets), such as weather forecasts,

news tickers, system information displays, or music player controls, onto your desktop, in a

symbiotic relationship of eye candy and usefulness.

1. Install the gdesklets and gdesklets-data packages from the Universe repository (see

Chapter 2, Adding, Removing and Updating Applications [p. 21]).

2. Choose: Applications → Accessories → gDesklets

3. For more information, visit the gDesklets website [http://www.gdesklets.org/]

1.14. Hide Recent Documents in the Places menu

To hide Recent Documents from the Places menu, open a terminal and run the command:

chmod 400 ~/.recently-used

To enable it again, run the command:

chmod 600 ~/.recently-used

1.15. Show the Computer, Home, and Trash desktop icons in GNOME

1. Open the Configuration Editor, by running the program gconf-editor (see

Section 1.2, “Start a Program Manually” [p. 51] ).

2. Choose apps → nautilus → desktop.

3. Tick the box beside computer_icon_visible, home_icon_visible, and

trash_icon_visible. The changes take effect immediately.

1.16. Change my preferred email client to Mozilla Thunderbird

1. Choose System → Preferences → Preferred Applications

2. Click on the Mail Reader tab, and select the Custom option.

3. In the Command text box, type  mozilla-thunderbird %s, then close the dialog.

1.17. Restart GNOME without rebooting the computer

1. Save and close all open applications.

2. Use the Ctrl-Alt-Backspace shortcut keys to restart GNOME.

3. If Ctrl-Alt-Backspace is disabled, type

http://www.gdesklets.org/
http://www.gdesklets.org/
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sudo /etc/init.d/gdm restart

(See Section 1.18, “Preventing the Ctrl-Alt-Backspace shortcut keys from restarting

X” [p. 56]  to disable Ctrl-Alt-Backspace.)

1.18. Preventing the Ctrl-Alt-Backspace shortcut keys from restarting X

1. Make a backup copy of your existing /etc/X11/xorg.conf file:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup

2. Open /etc/X11/xorg.conf for editing:

gksudo gedit /etc/X11/xorg.conf

3. Add the following lines to the end of the file:

Section "ServerFlags"

Option "DontZap" "yes"

EndSection

4. Save the edited file (an example [../sample/xorg.conf_disablectrlaltbackspacegnome]).

5. The change will take effect the next time you log in to GNOME. If you want the

change to take effect immediately, restart GNOME manually. (See Section 1.17,

“Restart GNOME without rebooting the computer” [p. 55] .)

../sample/xorg.conf_disablectrlaltbackspacegnome
../sample/xorg.conf_disablectrlaltbackspacegnome
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2. Partitions and Booting

2.1. Graphical Partition Editor

Gparted is a graphical tool to edit disk partitions.

1. Install the gparted package (see Chapter 2, Adding, Removing and Updating

Applications [p. 21]).

2. You can run the application with System → Administration  → Gnome Partition

Editor .

2.2. Make partitions available from Ubuntu

Windows and other partitions should be automatically available from any Ubuntu system.

If they are not, you can enable them using the graphical disks tool.

1. Open System → Administration → Disks

2. Select the correct hard disk, and click the Partitions tab.

3. Select the relevant partition, and click Enable.

4. To unmount the partition, click Disable.

2.3. Make partitions automatically available

Again, Windows and other partitions should be automatically available from Ubuntu. If

they are not, the following procedure will make them automatically available:

1. Read Section 3.7.1, “Check disk space usage and view the partition table” [p. 63]

2. First make a directory where the partition can be made available ("mounted"):

sudo mkdir /media/windows

       

3. Next, backup your disk configuration file and open the file in a text editor with

administrative privileges:

sudo cp /etc/fstab /etc/fstab_backup

gksudo gedit /etc/fstab

      

4. Append the following line at the end of file:

/dev/hda1 /media/windows ntfs umask=0222 0 0

Replace /dev/hda1 with the correct device name for your partition.

If your Windows partition uses the FAT32 filesystem, replace ntfs with vfat

in the above command.
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If you have a FAT32 filesystem, it is also safe to allow read-write access. To

do this, change the value of umask to 0000.

5. Save the edited file (an example [../sample/fstab_automountntfs])

6. The changes will take effect when the computer is restarted.

2.4. Run a system command automatically at startup

Sometimes it can be useful to add a custom command to the startup process so that your

computer executes it on every boot. To do this:

1. Edit the crontab with administrative privileges (see Section 3.3, “Root And Sudo” [p.

17]):

sudo crontab -e

2. Insert the following line:

@reboot /home/user/command

Replace /home/user/command with the full address to your command.

3. Save the file and exit.

2.5. Change default Operating System at boot

To change the Operating System which starts by default when booting, it is necessary to

edit the configuration file for booting.

1. Make a backup of your boot configuration file, and open it in a text editor:

sudo cp /boot/grub/menu.lst /boot/grub/menu.lst_backup

gksudo gedit /boot/grub/menu.lst

2. Find this line:

...

default 0

...

3. Replace with the following line:

default X_sequence

4. Save the edited file (an example [../sample/menu.list_changedefaultosgrub])

2.6. Permanently disable/enable boot-up services

This requires administrative privileges (see Section 3.3, “Root And Sudo” [p. 17]).

1. Run Services Settings: System → Administration → Services.

2. Enter your password.

../sample/fstab_automountntfs
../sample/fstab_automountntfs
../sample/menu.list_changedefaultosgrub
../sample/menu.list_changedefaultosgrub
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3. Tick/untick the services you want running, then click OK when done.

4. For greater control over the boot-up services, install the bum from the Universe

repository (see Chapter 2, Adding, Removing and Updating Applications [p. 21]) and

run it: System → Administration → Boot-up Manager.
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3. Hardware

3.1. Digital Cameras

Most USB digital cameras will be automatically detected by Ubuntu. Simply plug in and

switch on your USB digital camera, Ubuntu will then ask you if you would like to import

the photos from your camera. Click on Import, Ubuntu will then show you a preview of

your photos. Choose a location to save your photos to, then click on Import, Ubuntu will

then save your photos to your hard drive.

If you do not get the auto-import popup with your camera, it might be worth starting

gThumb and trying File → Import Photos.... See Section 6.1, “gThumb Image Viewer” [p.

45] for more on gThumb.

3.2. 3D Graphic Cards

3.2.1. Introduction to 3D Video Acceleration

Most video hardware should work automatically with Ubuntu. However with some types

of video hardware, 3D acceleration (which is needed by some games) will not be supported

automatically. This section details how to get this working with some popular video

hardware.

The first step is to find out whether 3D acceleration is working.

1. To do this, enter in a terminal:

glxinfo | grep rendering

2. If 3D acceleration is working, the following will be displayed:

direct rendering: Yes

3. If not, follow the instructions in the following sections to activate 3D acceleration.

3.2.2. 3D Nvidia Video Card Driver

No Nvidia Video cards have 3D acceleration enabled automatically with Ubuntu, because

the manufacturer does not release open source drivers. However, it is possible to activate

3D acceleration. The process depends on which type of video card you have.

1. If you have an older TNT, TNT2, TNT Ultra, GeForce1 or GeForce2 card, install

the nvidia-glx-legacy and nvidia-settings packages from the Restricted repository (see

Chapter 2, Adding, Removing and Updating Applications [p. 21]).

2. Alternatively, if you have a newer card, install the nvidia-glx package from the

Restricted repository (see Chapter 2, Adding, Removing and Updating Applications

[p. 21]).

3. To enable the new driver, run the following command in a terminal:
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sudo nvidia-glx-config enable 

4. You may adjust the settings of the new drivers by running the application

nvidia-settings (see Section 1.2, “Start a Program Manually” [p. 51]). If you wish,

add a menu entry for this program (see Section 1.1, “Menu Editing” [p. 51]).

3.2.3. 3D ATI Video Card Driver

Many ATI video cards work well with Ubuntu automatically. To check that 3d acceleration

works with your card, see Section 3.2.1, “Introduction to 3D Video Acceleration” [p.

60] . If it does not work, this procedure should activate it.

1. Install the xorg-driver-fglrx package from the Restricted repository (see Chapter 2,

Adding, Removing and Updating Applications [p. 21]).

2. You now need to configure the computer to use the new driver so run this command

in a terminal:

sudo dpkg-reconfigure xserver-xorg

3. When the dialogue appears and asks whether to do automatic detection of your video,

pick Yes.

4. When asked to select a driver, pick fglrx.

5. Follow the remaining instructions as appropriate.

6. Restart your machine for changes to take effect.

3.3. Keyboard Layouts

This section deals with adding keyboard layouts to your system, and switching between

them easily.

3.3.1. Add a Layout

To add a keyboard layout to your system:

1. Go to System → Preferences → Keyboard

2. Choose Layouts

3. Press Add... to add further keyboard layouts. It is simpler to have two layouts; the

maximum is currently four.

4. Close the dialogue.

3.3.2. Switch Keyboard Layouts

To switch between keyboard layouts, you can set a key combination:

1. Go to System → Preferences → Keyboard

2. To configure your layouts, choose Layout Options
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3. Expand the Group Shift/Lock behaviour option

4. Choose the key combination that enables you to switch between keyboard layouts.

The default is by pressing both Alt keys at the same time. A common alternative is to

use Alt-Shift.

5. Close the dialogue

6. You can now use your key combination to switch between keyboard layouts.

3.3.3. Keyboard Indicator

Alternatively add the Keyboard Indicator applet to your panel:

1. Right-click on an empty space on the panel where you want to add the applet

2. Click Add to Panel...

3. Choose Keyboard Indicator from the Utilities section

4. You can now right-click on the Keyboard Indicator to manage your keyboard layouts.

3.4. Wireless Cards

Many wireless cards are automatically detected by Ubuntu during installation. A

complete listing of wireless cards which work with Ubuntu can be found on Ubuntu Wiki

[https://wiki.ubuntu.com/HardwareSupportComponentsWirelessNetworkCards]. Please

add your wireless card to the list if it works with Ubuntu.

Some cards may not work automatically with Ubuntu. If this is the case, please look at the

Wireless Troubleshooting Guide [https://wiki.ubuntu.com/WirelessTroubleshootingGuide]

on the Ubuntu Wiki which is an excellent resource for troubleshooting wireless cards.

All information regarding wireless networking on Ubuntu is collected at Wireless

Networking Central [https://wiki.ubuntu.com/WifiDocs] on the Ubuntu Wiki.

3.5. Modems

3.5.1. Winmodems

Most winmodems are not supported by Ubuntu, but drivers can be found that will enable

the use of such modems. First you need to identify what chipset your winmodem is using:

wget -c http://linmodems.technion.ac.il/packages/scanModem.gz 

gunzip -c scanModem.gz > scanModem 

chmod +x scanModem

sudo ./scanModem 

gedit Modem/ModemData.txt

Read this file, it should list what modem chipset you have. Once you are

aware of the chipset you have, see http://www.linmodems.org/ and follow the

https://wiki.ubuntu.com/HardwareSupportComponentsWirelessNetworkCards
https://wiki.ubuntu.com/HardwareSupportComponentsWirelessNetworkCards
https://wiki.ubuntu.com/WirelessTroubleshootingGuide
https://wiki.ubuntu.com/WirelessTroubleshootingGuide
https://wiki.ubuntu.com/WifiDocs
https://wiki.ubuntu.com/WifiDocs
https://wiki.ubuntu.com/WifiDocs
http://linmodems.technion.ac.il/packages/scanModem.gz
http://www.linmodems.org/
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directions for your modem. More infomation can be found at SettingUpModems

[https://wiki.ubuntu.com/SettingUpModems] on the Ubuntu Wiki.

3.5.2. ADSL Modems

All PPPOE and router-style ADSL modems are supported by Ubuntu (that use ethernet

for the connections), and some USB ADSL modems are supported too. For router-style

ADSL modems, just connect it up, configure the modem as per your ISPs instructions

and configure networking in Ubuntu. For information on PPPOE modems see this guide

[https://wiki.ubuntu.com/ADSLPPPoE] on the Ubuntu wiki.

3.6. Printers

Some printers will be automatically detected by Ubuntu; for those that are not, choose

System → Administration → Printing then choose Printer → Add Printer and run the

Printer Install Wizard.

There are some printers that need further setup. Search the databases at LinuxPrinting.org

[http://www.linuxprinting.org/] or check the Ubuntu Wiki's Printer page

[https://wiki.ubuntu.com/HardwareSupportComponentsPrinters] for possible information

on your printer.

3.7. Other Tips

3.7.1. Check disk space usage and view the partition table

1. Launch System → Administration → Disks

2. Select the Harddrive, then the Partitions tab

3. Each partition will be listed under Partition List, with disk space and mount point.

3.7.2. List devices

1. To list mounted devices, run the following command in a terminal:

mount

The listing shows the device (such as a hard disk partition), the mount point (where

you access the files), the filesystem type and the mount options.

This example shows the hda2 hard disk partition mounted as '/', with the filesystem

type ext3. The partition is mounted with two options, one to allow the device to be

read from and wrote to and the other to remount the device as read only in the event of

any errors.

/dev/hda2 on / type ext3 (rw,errors=remount-ro)

2. To list PCI devices:

lspci

https://wiki.ubuntu.com/SettingUpModems
https://wiki.ubuntu.com/SettingUpModems
https://wiki.ubuntu.com/ADSLPPPoE
https://wiki.ubuntu.com/ADSLPPPoE
http://www.linuxprinting.org/
http://www.linuxprinting.org/
https://wiki.ubuntu.com/HardwareSupportComponentsPrinters
https://wiki.ubuntu.com/HardwareSupportComponentsPrinters
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3. To list USB devices:

lsusb

3.7.3. Mount/unmount CD/DVD-ROMs manually, and show all hidden and associated files/folders

1. Assuming that /media/cdrom0/ is the location of CD/DVD-ROM

2. To mount CD/DVD-ROM:

sudo mount /media/cdrom0/ -o unhide

3. To unmount CD/DVD-ROM:

sudo umount /media/cdrom0/
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4. Networking

4.1. Change the Computer Name

1. System → Administration → Networking

2. Select the General tab. Enter the name of the computer in the Hostname field.

3. Click OK, close all open applications and reboot.

4.2. Networking Utilities

4.2.1. Firestarter Firewall

A firewall protects a computer system from unauthorized access. It is not normally

necessary to install a firewall on an Ubuntu system, because access to the system is closed

by default. However, if you run any services which you allow other computers to access

(for example, the Apache web server), it is advisable to install a firewall. Firestarter is a

program which allows you to control a firewall through a graphical interface.

1. Install the Firestarter package from the Universe repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

2. After it is installed, run Applications → System Tools → Firestarter to configure your

firewall. The firewall will now start in the background when your computer starts.

4.2.2. Graphical Network Monitor

Etherape displays network activity among different hosts using circles of varying size.

1. Install the etherape package from the Universe repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

2. Choose: Applications → Internet → Etherape

4.2.3. Network Traffic Analyzer

Ethereal is a network traffic analyzer/sniffer that captures packets off the network in real

time and displays the contents of them.

1. Install the ethereal package from the Universe repository (see Chapter 2, Adding,

Removing and Updating Applications [p. 21]).

2. Choose: Applications → Internet → Ethereal
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Chapter 5. Getting More Help
There are a number of places from which you can obtain help with your Ubuntu desktop

system, these include:

• The Ubuntu Documentation Website [http://help.ubuntu.com] - this contains this

guide, and other guides produced by the Ubuntu Documentation Team for Ubuntu and

Kubuntu.

• The Ubuntu Wiki [https://wiki.ubuntu.com/UserDocumentation] - this contains many

guides contributed by the community.

• Web Forums [http://www.ubuntu.com/community/forums] - here you can ask questions

on a forum and receive answers from the forum community.

• Mailing Lists [http://lists.ubuntu.com] - here you can ask questions by email, and receive

answers from the mailing list community.

• IRC chat: irc.freenode.net channel #ubuntu - chat in realtime with the irc community.

You will need an irc client to connect. Ubuntu comes with a messenger client, open

Applications → Internet → Gaim Internet Messenger .

For more information, visit the How to Get Help [https://wiki.ubuntu.com/HowToGetHelp]

wiki page.

http://help.ubuntu.com
http://help.ubuntu.com
https://wiki.ubuntu.com/UserDocumentation
https://wiki.ubuntu.com/UserDocumentation
http://www.ubuntu.com/community/forums
http://www.ubuntu.com/community/forums
http://lists.ubuntu.com
http://lists.ubuntu.com
https://wiki.ubuntu.com/HowToGetHelp
https://wiki.ubuntu.com/HowToGetHelp
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Appendix A. Creative Commons by

Attribution-ShareAlike 2.0
CREATIVE COMMONS CORPORATION IS NOT A LAW FIRM AND DOES NOT

PROVIDE LEGAL SERVICES. DISTRIBUTION OF THIS LICENSE DOES NOT

CREATE AN ATTORNEY-CLIENT RELATIONSHIP. CREATIVE COMMONS

PROVIDES THIS INFORMATION ON AN "AS-IS" BASIS. CREATIVE COMMONS

MAKES NO WARRANTIES REGARDING THE INFORMATION PROVIDED, AND

DISCLAIMS LIABILITY FOR DAMAGES RESULTING FROM ITS USE.

License

THE WORK (AS DEFINED BELOW) IS PROVIDED UNDER THE TERMS OF THIS

CREATIVE COMMONS PUBLIC LICENSE ("CCPL" OR "LICENSE"). THE WORK

IS PROTECTED BY COPYRIGHT AND/OR OTHER APPLICABLE LAW. ANY USE

OF THE WORK OTHER THAN AS AUTHORIZED UNDER THIS LICENSE OR

COPYRIGHT LAW IS PROHIBITED.

BY EXERCISING ANY RIGHTS TO THE WORK PROVIDED HERE, YOU ACCEPT

AND AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE. THE LICENSOR

GRANTS YOU THE RIGHTS CONTAINED HERE IN CONSIDERATION OF YOUR

ACCEPTANCE OF SUCH TERMS AND CONDITIONS.

1. Definitions.

a. "Collective Work" means a work, such as a periodical issue, anthology or

encyclopedia, in which the Work in its entirety in unmodified form, along with

a number of other contributions, constituting separate and independent works

in themselves, are assembled into a collective whole. A work that constitutes a

Collective Work will not be considered a Derivative Work (as defined below) for the

purposes of this License.

b. "Derivative Work" means a work based upon the Work or upon the Work and

other pre-existing works, such as a translation, musical arrangement, dramatization,

fictionalization, motion picture version, sound recording, art reproduction,

abridgment, condensation, or any other form in which the Work may be recast,

transformed, or adapted, except that a work that constitutes a Collective Work

will not be considered a Derivative Work for the purpose of this License. For the

avoidance of doubt, where the Work is a musical composition or sound recording,

the synchronization of the Work in timed-relation with a moving image ("synching")

will be considered a Derivative Work for the purpose of this License.

c. "Licensor" means the individual or entity that offers the Work under the terms of

this License.
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d. "Original Author" means the individual or entity who created the Work.

e. "Work" means the copyrightable work of authorship offered under the terms of this

License.

f. "You" means an individual or entity exercising rights under this License who has

not previously violated the terms of this License with respect to the Work, or who

has received express permission from the Licensor to exercise rights under this

License despite a previous violation.

g. "License Elements" means the following high-level license attributes as selected by

Licensor and indicated in the title of this License: Attribution, ShareAlike.

2. Fair Use Rights. Nothing in this license is intended to reduce, limit, or restrict any

rights arising from fair use, first sale or other limitations on the exclusive rights of the

copyright owner under copyright law or other applicable laws.

3. License Grant. Subject to the terms and conditions of this License, Licensor hereby

grants You a worldwide, royalty-free, non-exclusive, perpetual (for the duration of the

applicable copyright) license to exercise the rights in the Work as stated below:

a. to reproduce the Work, to incorporate the Work into one or more Collective Works,

and to reproduce the Work as incorporated in the Collective Works;

b. to create and reproduce Derivative Works;

c. to distribute copies or phonorecords of, display publicly, perform publicly, and

perform publicly by means of a digital audio transmission the Work including as

incorporated in Collective Works;

d. to distribute copies or phonorecords of, display publicly, perform publicly, and

perform publicly by means of a digital audio transmission Derivative Works.

e. For the avoidance of doubt, where the work is a musical composition:

i. "Performance Royalties Under Blanket Licenses." Licensor waives the

exclusive right to collect, whether individually or via a performance rights society

(e.g. ASCAP, BMI, SESAC), royalties for the public performance or public

digital performance (e.g. webcast) of the Work.

ii. "Mechanical Rights and Statutory Royalties." Licensor waives the exclusive

right to collect, whether individually or via a music rights society or designated

agent (e.g. Harry Fox Agency), royalties for any phonorecord You create from

the Work ("cover version") and distribute, subject to the compulsory license

created by 17 USC Section 115 of the US Copyright Act (or the equivalent in

other jurisdictions).

f. "Webcasting Rights and Statutory Royalties." For the avoidance of doubt,

where the Work is a sound recording, Licensor waives the exclusive right to collect,

whether individually or via a performance-rights society (e.g. SoundExchange),

royalties for the public digital performance (e.g. webcast) of the Work, subject to the
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compulsory license created by 17 USC Section 114 of the US Copyright Act (or the

equivalent in other jurisdictions).

The above rights may be exercised in all media and formats whether now known or

hereafter devised. The above rights include the right to make such modifications as are

technically necessary to exercise the rights in other media and formats. All rights not

expressly granted by Licensor are hereby reserved.

4. Restrictions. The license granted in Section 3 above is expressly made subject to and

limited by the following restrictions:

a. You may distribute, publicly display, publicly perform, or publicly digitally perform

the Work only under the terms of this License, and You must include a copy of, or

the Uniform Resource Identifier for, this License with every copy or phonorecord

of the Work You distribute, publicly display, publicly perform, or publicly digitally

perform. You may not offer or impose any terms on the Work that alter or restrict

the terms of this License or the recipients' exercise of the rights granted hereunder.

You may not sublicense the Work. You must keep intact all notices that refer to this

License and to the disclaimer of warranties. You may not distribute, publicly display,

publicly perform, or publicly digitally perform the Work with any technological

measures that control access or use of the Work in a manner inconsistent with the

terms of this License Agreement. The above applies to the Work as incorporated

in a Collective Work, but this does not require the Collective Work apart from the

Work itself to be made subject to the terms of this License. If You create a Collective

Work, upon notice from any Licensor You must, to the extent practicable, remove

from the Collective Work any reference to such Licensor or the Original Author,

as requested. If You create a Derivative Work, upon notice from any Licensor You

must, to the extent practicable, remove from the Derivative Work any reference to

such Licensor or the Original Author, as requested.

b. You may distribute, publicly display, publicly perform, or publicly digitally perform

a Derivative Work only under the terms of this License, a later version of this

License with the same License Elements as this License, or a Creative Commons

iCommons license that contains the same License Elements as this License (e.g.

Attribution-ShareAlike 2.0 Japan). You must include a copy of, or the Uniform

Resource Identifier for, this License or other license specified in the previous

sentence with every copy or phonorecord of each Derivative Work You distribute,

publicly display, publicly perform, or publicly digitally perform. You may not offer

or impose any terms on the Derivative Works that alter or restrict the terms of this

License or the recipients' exercise of the rights granted hereunder, and You must

keep intact all notices that refer to this License and to the disclaimer of warranties.

You may not distribute, publicly display, publicly perform, or publicly digitally

perform the Derivative Work with any technological measures that control access or

use of the Work in a manner inconsistent with the terms of this License Agreement.

The above applies to the Derivative Work as incorporated in a Collective Work, but
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this does not require the Collective Work apart from the Derivative Work itself to be

made subject to the terms of this License.

c. If you distribute, publicly display, publicly perform, or publicly digitally perform

the Work or any Derivative Works or Collective Works, You must keep intact all

copyright notices for the Work and give the Original Author credit reasonable to

the medium or means You are utilizing by conveying the name (or pseudonym if

applicable) of the Original Author if supplied; the title of the Work if supplied;

to the extent reasonably practicable, the Uniform Resource Identifier, if any, that

Licensor specifies to be associated with the Work, unless such URI does not refer

to the copyright notice or licensing information for the Work; and in the case of a

Derivative Work, a credit identifying the use of the Work in the Derivative Work

(e.g., "French translation of the Work by Original Author," or "Screenplay based

on original Work by Original Author"). Such credit may be implemented in any

reasonable manner; provided, however, that in the case of a Derivative Work or

Collective Work, at a minimum such credit will appear where any other comparable

authorship credit appears and in a manner at least as prominent as such other

comparable authorship credit.

5. Representations, Warranties and Disclaimer

UNLESS OTHERWISE AGREED TO BY THE PARTIES IN WRITING,

LICENSOR OFFERS THE WORK AS-IS AND MAKES NO REPRESENTATIONS

OR WARRANTIES OF ANY KIND CONCERNING THE MATERIALS,

EXPRESS, IMPLIED, STATUTORY OR OTHERWISE, INCLUDING, WITHOUT

LIMITATION, WARRANTIES OF TITLE, MERCHANTIBILITY, FITNESS FOR

A PARTICULAR PURPOSE, NONINFRINGEMENT, OR THE ABSENCE OF

LATENT OR OTHER DEFECTS, ACCURACY, OR THE PRESENCE OF ABSENCE

OF ERRORS, WHETHER OR NOT DISCOVERABLE. SOME JURISDICTIONS

DO NOT ALLOW THE EXCLUSION OF IMPLIED WARRANTIES, SO SUCH

EXCLUSION MAY NOT APPLY TO YOU.

6. Limitation on Liability. EXCEPT TO THE EXTENT REQUIRED BY APPLICABLE

LAW, IN NO EVENT WILL LICENSOR BE LIABLE TO YOU ON ANY LEGAL

THEORY FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE OR

EXEMPLARY DAMAGES ARISING OUT OF THIS LICENSE OR THE USE OF

THE WORK, EVEN IF LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY

OF SUCH DAMAGES.

7. Termination

a. This License and the rights granted hereunder will terminate automatically upon any

breach by You of the terms of this License. Individuals or entities who have received

Derivative Works or Collective Works from You under this License, however, will

not have their licenses terminated provided such individuals or entities remain in
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full compliance with those licenses. Sections 1, 2, 5, 6, 7, and 8 will survive any

termination of this License.

b. Subject to the above terms and conditions, the license granted here is perpetual (for

the duration of the applicable copyright in the Work). Notwithstanding the above,

Licensor reserves the right to release the Work under different license terms or to

stop distributing the Work at any time; provided, however that any such election will

not serve to withdraw this License (or any other license that has been, or is required

to be, granted under the terms of this License), and this License will continue in full

force and effect unless terminated as stated above.

8. Miscellaneous

a. Each time You distribute or publicly digitally perform the Work or a Collective

Work, the Licensor offers to the recipient a license to the Work on the same terms

and conditions as the license granted to You under this License.

b. Each time You distribute or publicly digitally perform a Derivative Work, Licensor

offers to the recipient a license to the original Work on the same terms and

conditions as the license granted to You under this License.

c. If any provision of this License is invalid or unenforceable under applicable law,

it shall not affect the validity or enforceability of the remainder of the terms of this

License, and without further action by the parties to this agreement, such provision

shall be reformed to the minimum extent necessary to make such provision valid and

enforceable.

d. No term or provision of this License shall be deemed waived and no breach

consented to unless such waiver or consent shall be in writing and signed by the

party to be charged with such waiver or consent.

e. This License constitutes the entire agreement between the parties with respect to the

Work licensed here. There are no understandings, agreements or representations with

respect to the Work not specified here. Licensor shall not be bound by any additional

provisions that may appear in any communication from You. This License may not

be modified without the mutual written agreement of the Licensor and You.

Creative Commons is not a party to this License, and makes no warranty whatsoever

in connection with the Work. Creative Commons will not be liable to You or any party

on any legal theory for any damages whatsoever, including without limitation any

general, special, incidental or consequential damages arising in connection to this license.

Notwithstanding the foregoing two (2) sentences, if Creative Commons has expressly

identified itself as the Licensor hereunder, it shall have all rights and obligations of

Licensor.

Except for the limited purpose of indicating to the public that the Work is licensed under

the CCPL, neither party will use the trademark "Creative Commons" or any related

trademark or logo of Creative Commons without the prior written consent of Creative
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Commons. Any permitted use will be in compliance with Creative Commons' then-current

trademark usage guidelines, as may be published on its website or otherwise made

available upon request from time to time.

Creative Commons may be contacted at http://creativecommons.org/.

http://creativecommons.org/
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Appendix B. GNU Free Documentation

License
Version 1.2, November 2002

Copyright © 2000,2001,2002 Free Software Foundation, Inc.

Free Software Foundation, Inc.

 51 Franklin St, Fifth Floor,

 Boston,

 MA

 02110-1301

 USA

 

Everyone is permitted to copy and distribute verbatim copies of this license document, but

changing it is not allowed.

Version 1.2, November 2002

PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional and useful

document "free" in the sense of freedom: to assure everyone the effective freedom to copy

and redistribute it, with or without modifying it, either commercially or noncommercially.

Secondarily, this License preserves for the author and publisher a way to get credit for their

work, while not being considered responsible for modifications made by others.

This License is a kind of "copyleft", which means that derivative works of the document

must themselves be free in the same sense. It complements the GNU General Public

License, which is a copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software, because free

software needs free documentation: a free program should come with manuals providing

the same freedoms that the software does. But this License is not limited to software

manuals; it can be used for any textual work, regardless of subject matter or whether it

is published as a printed book. We recommend this License principally for works whose

purpose is instruction or reference.

APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that contains a notice

placed by the copyright holder saying it can be distributed under the terms of this License.

Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use

that work under the conditions stated herein. The "Document", below, refers to any such
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manual or work. Any member of the public is a licensee, and is addressed as "you". You

accept the license if you copy, modify or distribute the work in a way requiring permission

under copyright law.

A "Modified Version" of the Document means any work containing the Document or a

portion of it, either copied verbatim, or with modifications and/or translated into another

language.

A "Secondary Section" is a named appendix or a front-matter section of the Document

that deals exclusively with the relationship of the publishers or authors of the Document

to the Document's overall subject (or to related matters) and contains nothing that could

fall directly within that overall subject. (Thus, if the Document is in part a textbook of

mathematics, a Secondary Section may not explain any mathematics.) The relationship

could be a matter of historical connection with the subject or with related matters, or of

legal, commercial, philosophical, ethical or political position regarding them.

The "Invariant Sections" are certain Secondary Sections whose titles are designated, as

being those of Invariant Sections, in the notice that says that the Document is released

under this License. If a section does not fit the above definition of Secondary then it is not

allowed to be designated as Invariant. The Document may contain zero Invariant Sections.

If the Document does not identify any Invariant Sections then there are none.

The "Cover Texts" are certain short passages of text that are listed, as Front-Cover Texts or

Back-Cover Texts, in the notice that says that the Document is released under this License.

A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25

words.

A "Transparent" copy of the Document means a machine-readable copy, represented in a

format whose specification is available to the general public, that is suitable for revising

the document straightforwardly with generic text editors or (for images composed of

pixels) generic paint programs or (for drawings) some widely available drawing editor,

and that is suitable for input to text formatters or for automatic translation to a variety of

formats suitable for input to text formatters. A copy made in an otherwise Transparent file

format whose markup, or absence of markup, has been arranged to thwart or discourage

subsequent modification by readers is not Transparent. An image format is not Transparent

if used for any substantial amount of text. A copy that is not "Transparent" is called

"Opaque".

Examples of suitable formats for Transparent copies include plain ASCII without markup,

Texinfo input format, LaTeX input format, SGML or XML using a publicly available

DTD, and standard-conforming simple HTML, PostScript or PDF designed for human

modification. Examples of transparent image formats include PNG, XCF and JPG. Opaque

formats include proprietary formats that can be read and edited only by proprietary word

processors, SGML or XML for which the DTD and/or processing tools are not generally
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available, and the machine-generated HTML, PostScript or PDF produced by some word

processors for output purposes only.

The "Title Page" means, for a printed book, the title page itself, plus such following pages

as are needed to hold, legibly, the material this License requires to appear in the title page.

For works in formats which do not have any title page as such, "Title Page" means the

text near the most prominent appearance of the work's title, preceding the beginning of the

body of the text.

A section "Entitled XYZ" means a named subunit of the Document whose title either

is precisely XYZ or contains XYZ in parentheses following text that translates XYZ in

another language. (Here XYZ stands for a specific section name mentioned below, such

as "Acknowledgements", "Dedications", "Endorsements", or "History".) To "Preserve the

Title" of such a section when you modify the Document means that it remains a section

"Entitled XYZ" according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that

this License applies to the Document. These Warranty Disclaimers are considered to be

included by reference in this License, but only as regards disclaiming warranties: any other

implication that these Warranty Disclaimers may have is void and has no effect on the

meaning of this License.

VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or

noncommercially, provided that this License, the copyright notices, and the license notice

saying this License applies to the Document are reproduced in all copies, and that you

add no other conditions whatsoever to those of this License. You may not use technical

measures to obstruct or control the reading or further copying of the copies you make

or distribute. However, you may accept compensation in exchange for copies. If you

distribute a large enough number of copies you must also follow the conditions in section

3.

You may also lend copies, under the same conditions stated above, and you may publicly

display copies.

COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed covers)

of the Document, numbering more than 100, and the Document's license notice requires

Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all

these Cover Texts: Front-Cover Texts on the front cover, and Back-Cover Texts on the

back cover. Both covers must also clearly and legibly identify you as the publisher of

these copies. The front cover must present the full title with all words of the title equally

prominent and visible. You may add other material on the covers in addition. Copying with
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changes limited to the covers, as long as they preserve the title of the Document and satisfy

these conditions, can be treated as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the

first ones listed (as many as fit reasonably) on the actual cover, and continue the rest onto

adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you

must either include a machine-readable Transparent copy along with each Opaque copy,

or state in or with each Opaque copy a computer-network location from which the general

network-using public has access to download using public-standard network protocols a

complete Transparent copy of the Document, free of added material. If you use the latter

option, you must take reasonably prudent steps, when you begin distribution of Opaque

copies in quantity, to ensure that this Transparent copy will remain thus accessible at the

stated location until at least one year after the last time you distribute an Opaque copy

(directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before

redistributing any large number of copies, to give them a chance to provide you with an

updated version of the Document.

MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions

of sections 2 and 3 above, provided that you release the Modified Version under precisely

this License, with the Modified Version filling the role of the Document, thus licensing

distribution and modification of the Modified Version to whoever possesses a copy of it. In

addition, you must do these things in the Modified Version:

GNU FDL Modification Conditions

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the

Document, and from those of previous versions (which should, if there were any, be

listed in the History section of the Document). You may use the same title as a previous

version if the original publisher of that version gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for

authorship of the modifications in the Modified Version, together with at least five of

the principal authors of the Document (all of its principal authors, if it has fewer than

five), unless they release you from this requirement.

C. State on the Title page the name of the publisher of the Modified Version, as the

publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to the other

copyright notices.
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F. Include, immediately after the copyright notices, a license notice giving the public

permission to use the Modified Version under the terms of this License, in the form

shown in the Addendum [p. 80]  below.

G. Preserve in that license notice the full lists of Invariant Sections and required Cover

Texts given in the Document's license notice.

H. Include an unaltered copy of this License.

I. Preserve the section Entitled "History", Preserve its Title, and add to it an item stating at

least the title, year, new authors, and publisher of the Modified Version as given on the

Title Page. If there is no section Entitled "History" in the Document, create one stating

the title, year, authors, and publisher of the Document as given on its Title Page, then

add an item describing the Modified Version as stated in the previous sentence.

J. Preserve the network location, if any, given in the Document for public access to a

Transparent copy of the Document, and likewise the network locations given in the

Document for previous versions it was based on. These may be placed in the "History"

section. You may omit a network location for a work that was published at least four

years before the Document itself, or if the original publisher of the version it refers to

gives permission.

K. For any section Entitled "Acknowledgements" or "Dedications", Preserve the Title

of the section, and preserve in the section all the substance and tone of each of the

contributor acknowledgements and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their

titles. Section numbers or the equivalent are not considered part of the section titles.

M.Delete any section Entitled "Endorsements". Such a section may not be included in the

Modified Version.

N. Do not retitle any existing section to be Entitled "Endorsements" or to conflict in title

with any Invariant Section.

O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as

Secondary Sections and contain no material copied from the Document, you may at your

option designate some or all of these sections as invariant. To do this, add their titles to

the list of Invariant Sections in the Modified Version's license notice. These titles must be

distinct from any other section titles.

You may add a section Entitled "Endorsements", provided it contains nothing but

endorsements of your Modified Version by various parties--for example, statements of peer

review or that the text has been approved by an organization as the authoritative definition

of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up

to 25 words as a Back-Cover Text, to the end of the list of Cover Texts in the Modified
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Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added

by (or through arrangements made by) any one entity. If the Document already includes

a cover text for the same cover, previously added by you or by arrangement made by the

same entity you are acting on behalf of, you may not add another; but you may replace the

old one, on explicit permission from the previous publisher that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission

to use their names for publicity for or to assert or imply endorsement of any Modified

Version.

COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under

the terms defined in section 4 [p. 76]  above for modified versions, provided that you

include in the combination all of the Invariant Sections of all of the original documents,

unmodified, and list them all as Invariant Sections of your combined work in its license

notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical

Invariant Sections may be replaced with a single copy. If there are multiple Invariant

Sections with the same name but different contents, make the title of each such section

unique by adding at the end of it, in parentheses, the name of the original author or

publisher of that section if known, or else a unique number. Make the same adjustment to

the section titles in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled "History" in the various

original documents, forming one section Entitled "History"; likewise combine any sections

Entitled "Acknowledgements", and any sections Entitled "Dedications". You must delete

all sections Entitled "Endorsements".

COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents released

under this License, and replace the individual copies of this License in the various

documents with a single copy that is included in the collection, provided that you follow

the rules of this License for verbatim copying of each of the documents in all other

respects.

You may extract a single document from such a collection, and distribute it individually

under this License, provided you insert a copy of this License into the extracted document,

and follow this License in all other respects regarding verbatim copying of that document.

AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent

documents or works, in or on a volume of a storage or distribution medium, is called an
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"aggregate" if the copyright resulting from the compilation is not used to limit the legal

rights of the compilation's users beyond what the individual works permit. When the

Document is included in an aggregate, this License does not apply to the other works in the

aggregate which are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document,

then if the Document is less than one half of the entire aggregate, the Document's Cover

Texts may be placed on covers that bracket the Document within the aggregate, or the

electronic equivalent of covers if the Document is in electronic form. Otherwise they must

appear on printed covers that bracket the whole aggregate.

TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the

Document under the terms of section 4. Replacing Invariant Sections with translations

requires special permission from their copyright holders, but you may include translations

of some or all Invariant Sections in addition to the original versions of these Invariant

Sections. You may include a translation of this License, and all the license notices in the

Document, and any Warranty Disclaimers, provided that you also include the original

English version of this License and the original versions of those notices and disclaimers.

In case of a disagreement between the translation and the original version of this License or

a notice or disclaimer, the original version will prevail.

If a section in the Document is Entitled "Acknowledgements", "Dedications", or "History",

the requirement (section 4) to Preserve its Title (section 1) will typically require changing

the actual title.

TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly

provided for under this License. Any other attempt to copy, modify, sublicense or

distribute the Document is void, and will automatically terminate your rights under this

License. However, parties who have received copies, or rights, from you under this License

will not have their licenses terminated so long as such parties remain in full compliance.

FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free

Documentation License from time to time. Such new versions will be similar in spirit to

the present version, but may differ in detail to address new problems or concerns. See

http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document

specifies that a particular numbered version of this License "or any later version" applies

to it, you have the option of following the terms and conditions either of that specified
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version or of any later version that has been published (not as a draft) by the Free Software

Foundation. If the Document does not specify a version number of this License, you may

choose any version ever published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents

To use this License in a document you have written, include a copy of the License in the

document and put the following copyright and license notices just after the title page:

Sample Invariant Sections list

Copyright (c) YEAR YOUR NAME. Permission is granted to copy,

distribute and/or modify this document under the terms of the GNU Free

Documentation License, Version 1.2 or any later version published by the

Free Software Foundation; with no Invariant Sections, no Front-Cover

Texts, and no Back-Cover Texts. A copy of the license is included in the

section entitled "GNU Free Documentation License".

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the

"with...Texts." line with this:

Sample Invariant Sections list

with the Invariant Sections being LIST THEIR TITLES, with the

Front-Cover Texts being LIST, and with the Back-Cover Texts being

LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the

three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing

these examples in parallel under your choice of free software license, such as the GNU

General Public License, to permit their use in free software.
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